Add bogus conditional branch before stlx
[oota-llvm.git] / examples / ExceptionDemo / CMakeLists.txt
index 0908892a16ceeb85c25478e15ced96bc7614455b..793cf291ca6f110eae23c396e24c2ee3cd050bcd 100644 (file)
@@ -5,12 +5,14 @@ set(LLVM_LINK_COMPONENTS
   MCJIT
   RuntimeDyld
   Support
+  Target
   nativecodegen
   )
 
 # Enable EH and RTTI for this demo
-set(LLVM_REQUIRES_EH 1)
-set(LLVM_REQUIRES_RTTI 1)
+if(NOT LLVM_ENABLE_EH)
+  message(FATAL_ERROR "ExceptionDemo must require EH.")
+endif()
 
 add_llvm_example(ExceptionDemo
   ExceptionDemo.cpp