Remove access to the DataLayout in the TargetMachine
[oota-llvm.git] / examples / CMakeLists.txt
index f60c0eda030612b50e69b91b6532e3abf2a82f8d..f98c403deb0b90ef3d6e9d8f73642374c44d847d 100644 (file)
@@ -4,13 +4,10 @@ add_subdirectory(HowToUseJIT)
 add_subdirectory(Kaleidoscope)
 add_subdirectory(ModuleMaker)
 
-if( NOT WIN32 )
+if( ( NOT WIN32 ) AND ( NOT "${LLVM_NATIVE_ARCH}" STREQUAL "ARM" ) )
     add_subdirectory(ExceptionDemo)
 endif()
 
-include(CheckIncludeFile)
-check_include_file(pthread.h HAVE_PTHREAD_H)
-
 if( HAVE_PTHREAD_H )
   add_subdirectory(ParallelJIT)
 endif( HAVE_PTHREAD_H )