Remove access to the DataLayout in the TargetMachine
[oota-llvm.git] / examples / CMakeLists.txt
index 54ee6cc3a3a41ee0188b8be3f5ecd8c338772c79..f98c403deb0b90ef3d6e9d8f73642374c44d847d 100644 (file)
@@ -4,7 +4,7 @@ add_subdirectory(HowToUseJIT)
 add_subdirectory(Kaleidoscope)
 add_subdirectory(ModuleMaker)
 
-if( NOT WIN32 )
+if( ( NOT WIN32 ) AND ( NOT "${LLVM_NATIVE_ARCH}" STREQUAL "ARM" ) )
     add_subdirectory(ExceptionDemo)
 endif()