[CMake] Update LLVM_LINK_COMPONENTS for each CMakeLists.txt.
[oota-llvm.git] / examples / CMakeLists.txt
index c5b80793e0b5919b76289b78081fd59f3a99be33..54ee6cc3a3a41ee0188b8be3f5ecd8c338772c79 100644 (file)
@@ -4,8 +4,9 @@ add_subdirectory(HowToUseJIT)
 add_subdirectory(Kaleidoscope)
 add_subdirectory(ModuleMaker)
 
-include(CheckIncludeFile)
-check_include_file(pthread.h HAVE_PTHREAD_H)
+if( NOT WIN32 )
+    add_subdirectory(ExceptionDemo)
+endif()
 
 if( HAVE_PTHREAD_H )
   add_subdirectory(ParallelJIT)