Do not re-test for the existence of pthread.h.
[oota-llvm.git] / examples / CMakeLists.txt
index b54adeb9be1f4df56c46597f510a86d434189cb4..54ee6cc3a3a41ee0188b8be3f5ecd8c338772c79 100644 (file)
@@ -3,10 +3,10 @@ add_subdirectory(Fibonacci)
 add_subdirectory(HowToUseJIT)
 add_subdirectory(Kaleidoscope)
 add_subdirectory(ModuleMaker)
-add_subdirectory(ExceptionDemo)
 
-include(CheckIncludeFile)
-check_include_file(pthread.h HAVE_PTHREAD_H)
+if( NOT WIN32 )
+    add_subdirectory(ExceptionDemo)
+endif()
 
 if( HAVE_PTHREAD_H )
   add_subdirectory(ParallelJIT)