CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally.
[oota-llvm.git] / examples / BrainF / CMakeLists.txt
index 7bec105cdc8a677d4cce4bc78d4ae52be8a7f4ba..4859634ed138afc2059da57c98db92ce0c6974ec 100644 (file)
@@ -1,6 +1,7 @@
-set(LLVM_LINK_COMPONENTS jit bitwriter nativecodegen interpreter)
-
 add_llvm_example(BrainF
   BrainF.cpp
   BrainFDriver.cpp
   )
+
+add_llvm_link_components(BrainF jit nativecodegen interpreter)
+target_link_libraries(BrainF LLVMBitWriter)