Make sure to default ${prefix} to /usr/local if the user didn't specify it.
[oota-llvm.git] / autoconf / configure.ac
index b29ce31f964db366a5b98d2adca6d6f2fc01392a..f6bb7a5445ee9458458b1a8b4d738102e58da7a3 100644 (file)
@@ -632,6 +632,9 @@ AC_SUBST(SHLIBEXT,$libltdl_cv_shlibext)
 # Translate the various configuration directories and other basic
 # information into substitutions that will end up in Makefile.config.in 
 # that these configured values can be used by the makefiles
+if test "${prefix}" == "NONE" ; then
+  prefix="/usr/local"
+fi
 eval LLVM_PREFIX="${prefix}";
 eval LLVM_BINDIR="${prefix}/bin";
 eval LLVM_LIBDIR="${prefix}/lib";