Modified the linker so that it always links in an object from an archive
[oota-llvm.git] / autoconf / configure.ac
index fa0aa331b5e5ba25b772b7910642a7dd8c99b060..ecabae9a9da37c4b88847afd403f57678585e873 100644 (file)
@@ -15,65 +15,45 @@ dnl AC_OUTPUT
 dnl **************************************************************************
 dnl * Initialize
 dnl **************************************************************************
-AC_INIT([[[LLVM]]],[[[1.0]]],[llvmbugs@cs.uiuc.edu])
+AC_INIT([[[LLVM]]],[[[1.1]]],[llvmbugs@cs.uiuc.edu])
 
 dnl Place all of the extra autoconf files into the config subdirectory
 AC_CONFIG_AUX_DIR([autoconf])
 
+dnl Quit if the source directory has already been configured.
+dnl NOTE: This relies upon undocumented autoconf behavior.
+if test ${srcdir} != "."
+then
+       if test -f ${srcdir}/include/Config/config.h
+       then
+               AC_MSG_ERROR([Already configured in ${srcdir}])
+       fi
+fi
+
+dnl
+dnl Configure all of the projects present in our source tree.
+dnl
+for i in `ls ${srcdir}/projects`
+do
+  if test ${i} != "CVS"
+  then
+    if test -f ${srcdir}/projects/${i}/configure
+    then
+      AC_CONFIG_SUBDIRS(projects/${i})
+    fi
+  fi
+done
+
 dnl Configure a header file
 AC_CONFIG_HEADERS(include/Config/config.h)
 AC_CONFIG_MAKEFILE(Makefile)
 AC_CONFIG_MAKEFILE(Makefile.common)
-AC_CONFIG_MAKEFILE(Makefile.rules)
 AC_CONFIG_MAKEFILE(lib/Makefile)
-AC_CONFIG_MAKEFILE(lib/Analysis/Makefile)
-AC_CONFIG_MAKEFILE(lib/Analysis/DataStructure/Makefile)
-AC_CONFIG_MAKEFILE(lib/Analysis/IPA/Makefile)
-AC_CONFIG_MAKEFILE(lib/Analysis/LiveVar/Makefile)
-AC_CONFIG_MAKEFILE(lib/AsmParser/Makefile)
-AC_CONFIG_MAKEFILE(lib/Bytecode/Makefile)
-AC_CONFIG_MAKEFILE(lib/Bytecode/Reader/Makefile)
-AC_CONFIG_MAKEFILE(lib/Bytecode/Writer/Makefile)
-AC_CONFIG_MAKEFILE(lib/CWriter/Makefile)
-AC_CONFIG_MAKEFILE(lib/CodeGen/Makefile)
-AC_CONFIG_MAKEFILE(lib/CodeGen/InstrSched/Makefile)
-AC_CONFIG_MAKEFILE(lib/CodeGen/InstrSelection/Makefile)
-AC_CONFIG_MAKEFILE(lib/CodeGen/ModuloScheduling/Makefile)
-AC_CONFIG_MAKEFILE(lib/CodeGen/RegAlloc/Makefile)
-AC_CONFIG_MAKEFILE(lib/CodeGen/SelectionDAG/Makefile)
-AC_CONFIG_MAKEFILE(lib/ExecutionEngine/Makefile)
-AC_CONFIG_MAKEFILE(lib/ExecutionEngine/Interpreter/Makefile)
-AC_CONFIG_MAKEFILE(lib/ExecutionEngine/JIT/Makefile)
-AC_CONFIG_MAKEFILE(lib/Support/Makefile)
-AC_CONFIG_MAKEFILE(lib/Target/Makefile)
-AC_CONFIG_MAKEFILE(lib/Target/Sparc/Makefile)
-AC_CONFIG_MAKEFILE(lib/Target/X86/Makefile)
-AC_CONFIG_MAKEFILE(lib/Transforms/Makefile)
-AC_CONFIG_MAKEFILE(lib/Transforms/Hello/Makefile)
-AC_CONFIG_MAKEFILE(lib/Transforms/IPO/Makefile)
-AC_CONFIG_MAKEFILE(lib/Transforms/Instrumentation/Makefile)
-AC_CONFIG_MAKEFILE(lib/Transforms/Instrumentation/ProfilePaths/Makefile)
-AC_CONFIG_MAKEFILE(lib/Transforms/Scalar/Makefile)
-AC_CONFIG_MAKEFILE(lib/Transforms/Utils/Makefile)
-AC_CONFIG_MAKEFILE(lib/VMCore/Makefile)
 AC_CONFIG_MAKEFILE(runtime/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/crtend/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libc/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libcurses/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libexception/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libg/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libgcc/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libm/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libmalloc/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libtermcap/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libucb/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libutempter/Makefile)
-AC_CONFIG_MAKEFILE(runtime/GCCLibraries/libutil/Makefile)
-AC_CONFIG_MAKEFILE(runtime/libdummy/Makefile)
-AC_CONFIG_MAKEFILE(runtime/libtrace/Makefile)
 AC_CONFIG_MAKEFILE(test/Makefile)
 AC_CONFIG_MAKEFILE(test/Makefile.tests)
+AC_CONFIG_MAKEFILE(test/QMTest/llvm.py)
+AC_CONFIG_MAKEFILE(test/QMTest/llvmdb.py)
 AC_CONFIG_MAKEFILE(test/Programs/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/Makefile.programs)
 AC_CONFIG_MAKEFILE(test/Programs/TEST.aa.Makefile)
@@ -93,111 +73,26 @@ AC_CONFIG_MAKEFILE(test/Programs/TEST.micro.Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/Makefile.spec)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CFP2000/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CFP2000/179.art/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CFP2000/183.equake/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CFP2000/188.ammp/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/164.gzip/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/175.vpr/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/176.gcc/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/181.mcf/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/186.crafty/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/197.parser/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/254.gap/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/255.vortex/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/256.bzip2/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/300.twolf/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/LLVMSource/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Makefile.multisrc)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Applications/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Applications/Burg/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Applications/aha/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Applications/sgefa/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Fhourstones/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/01-qbsort/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/03-testtrie/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/04-bisect/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/05-eks/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/08-main/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/09-vor/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/12-IOtest/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/15-trie/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/17-bintr/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/McCat/18-imp/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/bh/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/bisort/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/em3d/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/health/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/mst/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/perimeter/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/power/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/treeadd/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/tsp/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Olden/voronoi/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/OptimizerEval/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Ptrdist/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Ptrdist/anagram/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Ptrdist/bc/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Ptrdist/ft/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Ptrdist/ks/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Ptrdist/yacr2/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/llubenchmark/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/sim/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Flex/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Larn/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Moria-5.5.2/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Povray31/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/m4/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/analyzer/test.in)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/distray/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/distray/test.in)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/fourinarow/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/fourinarow/test.in)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/mason/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/mason/test.in)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/neural/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/neural/test.in)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/pcompress2/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/pcompress2/test.in)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/pifft/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/FreeBench/pifft/test.in)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Makefile.singlesrc)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Gizmos/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Benchmarks/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Benchmarks/Dhrystone/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Benchmarks/Shootout/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Benchmarks/Stanford/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Benchmarks/Misc/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/CustomChecked/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/UnitTests/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/UnitTests/SetjmpLongjmp/Makefile)
 AC_CONFIG_MAKEFILE(tools/Makefile)
-AC_CONFIG_MAKEFILE(tools/analyze/Makefile)
-AC_CONFIG_MAKEFILE(tools/as/Makefile)
-AC_CONFIG_MAKEFILE(tools/bugpoint/Makefile)
-AC_CONFIG_MAKEFILE(tools/dis/Makefile)
-AC_CONFIG_MAKEFILE(tools/extract/Makefile)
-AC_CONFIG_MAKEFILE(tools/gccas/Makefile)
-AC_CONFIG_MAKEFILE(tools/gccld/Makefile)
-AC_CONFIG_MAKEFILE(tools/link/Makefile)
-AC_CONFIG_MAKEFILE(tools/llc/Makefile)
-AC_CONFIG_MAKEFILE(tools/lli/Makefile)
-AC_CONFIG_MAKEFILE(tools/opt/Makefile)
-AC_CONFIG_MAKEFILE(tools/llee/Makefile)
-AC_CONFIG_MAKEFILE(tools/llvm-as/Makefile)
-AC_CONFIG_MAKEFILE(tools/llvm-ar/Makefile)
-AC_CONFIG_MAKEFILE(tools/llvm-dis/Makefile)
 AC_CONFIG_MAKEFILE(utils/Makefile)
-AC_CONFIG_MAKEFILE(utils/Burg/Makefile)
-AC_CONFIG_MAKEFILE(utils/Burg/Doc/Makefile)
-AC_CONFIG_MAKEFILE(utils/TableGen/Makefile)
-AC_CONFIG_MAKEFILE(www/docs/Makefile)
 AC_CONFIG_MAKEFILE(projects/Makefile)
-AC_CONFIG_MAKEFILE(projects/sample/Makefile)
-AC_CONFIG_MAKEFILE(projects/sample/Makefile.common)
-AC_CONFIG_MAKEFILE(projects/sample/Makefile.config)
-AC_CONFIG_MAKEFILE(projects/sample/lib/Makefile)
-AC_CONFIG_MAKEFILE(projects/sample/lib/sample/Makefile)
-AC_CONFIG_MAKEFILE(projects/sample/tools/Makefile)
-AC_CONFIG_MAKEFILE(projects/sample/tools/sample/Makefile)
-AC_CONFIG_MAKEFILE(projects/ModuleMaker/Makefile)
-AC_CONFIG_MAKEFILE(projects/ModuleMaker/Makefile.common)
-AC_CONFIG_MAKEFILE(projects/ModuleMaker/tools/Makefile)
-AC_CONFIG_MAKEFILE(projects/ModuleMaker/tools/ModuleMaker/Makefile)
 
 dnl **************************************************************************
 dnl * Determine which system we are building on
@@ -210,42 +105,52 @@ dnl Check which host for which we're compiling.  This will tell us which LLVM
 dnl compiler will be used for compiling SSA into object code.
 AC_CANONICAL_TARGET
 
-dnl
-dnl Now, for some of our own magic:
+dnl Set the "OS" Makefile variable based on the system we are building on.
 dnl We will use the build machine information to set some variables.
-dnl
 case $build in
-       *i*86*)  AC_SUBST(OS,[Linux])
-                AC_SUBST(LLVMGCCDIR,[/home/vadve/lattner/local/x86/llvm-gcc/])
+       *-*-linux*)
+             AC_SUBST(OS,[Linux])
+                        if test -d /home/vadve/lattner/local/x86/llvm-gcc
+                        then
+                          AC_SUBST(LLVMGCCDIR,[/home/vadve/lattner/local/x86/llvm-gcc/])
+                        fi
                 ;;
 
-       *sparc*) AC_SUBST(OS,[SunOS])
-                AC_SUBST(LLVMGCCDIR,[/home/vadve/lattner/local/sparc/llvm-gcc/])
+       *-*-solaris*)
+             AC_SUBST(OS,[SunOS])
+                        if test -d /home/vadve/lattner/local/sparc/llvm-gcc
+                        then
+                  AC_SUBST(LLVMGCCDIR,[/home/vadve/lattner/local/sparc/llvm-gcc/])
+                        fi
+                ;;
+
+       *-*-darwin*)
+             AC_SUBST(OS,[Darwin])
                 ;;
 
        *)       AC_SUBST(OS,[Unknown])
                 ;;
 esac
 
-dnl
 dnl If we are targetting a Sparc machine running Solaris, pretend that it is
 dnl V9, since that is all that we support at the moment, and autoconf will only
 dnl tell us we're a sparc.
-dnl
 case $target in
-       *sparc*solaris*)  AC_SUBST(target,[[sparcv9-sun-solaris2.8]])
-                         ;;
+       sparc*-*-solaris*)  AC_SUBST(target,[[sparcv9-sun-solaris2.8]])
+                           ;;
 esac
 
-dnl
 dnl Determine what our target architecture is and configure accordingly.
 dnl This will allow Makefiles to make a distinction between the hardware and
 dnl the OS.
-dnl
 case $target in
-       *i*86*)           AC_SUBST(ARCH,[x86])
+       i*86-*)           AC_SUBST(ARCH,[x86])
+                         ;;
+       sparc*-*)         AC_SUBST(ARCH,[Sparc])
+                         ;;
+       powerpc*-*)       AC_SUBST(ARCH,[PowerPC])
                          ;;
-       *sparc*solaris*)  AC_SUBST(ARCH,[Sparc])
+       *)                AC_SUBST(ARCH,[Unknown])
                          ;;
 esac
 
@@ -291,19 +196,69 @@ dnl Check for libtool
 AC_PROG_LIBTOOL
 
 dnl Check for our special programs
-AC_PATH_PROG(RPWD,[pwd])
-AC_PATH_PROG(AR,[ar])
-AC_PATH_PROG(SED,[sed])
-AC_PATH_PROG(RM,[rm])
-AC_PATH_PROG(ECHO,[echo])
-AC_PATH_PROG(MKDIR,[mkdir])
-AC_PATH_PROG(DATE,[date])
-AC_PATH_PROG(MV,[mv])
-AC_PATH_PROG(DOT,[dot])
-AC_PATH_PROG(ETAGS,[etags])
-AC_PATH_PROG(PURIFY,[purify])
-AC_PATH_PROG(PYTHON,[python])
-AC_PATH_PROG(QMTEST,[qmtest])
+AC_PATH_PROG(RPWD,[pwd],[false])
+if test ${RPWD} = "false"
+then
+       AC_MSG_ERROR([pwd required but not found])
+fi
+
+AC_PATH_PROG(AR,[ar],[false])
+if test ${AR} = "false"
+then
+       AC_MSG_ERROR([ar required but not found])
+fi
+
+AC_PATH_PROG(SED,[sed],[false])
+if test ${SED} = "false"
+then
+       AC_MSG_ERROR([sed required but not found])
+fi
+
+AC_PATH_PROG(RM,[rm],[false])
+if test ${RM} = "false"
+then
+       AC_MSG_ERROR([rm required but not found])
+fi
+
+AC_PATH_PROG(ECHO,[echo],[false])
+if test ${ECHO} = "false"
+then
+       AC_MSG_ERROR([echo required but not found])
+fi
+
+AC_PATH_PROG(MKDIR,[mkdir],[false])
+if test ${MKDIR} = "false"
+then
+       AC_MSG_ERROR([mkdir required but not found])
+fi
+
+AC_PATH_PROG(DATE,[date],[false])
+if test ${DATE} = "false"
+then
+       AC_MSG_ERROR([date required but not found])
+fi
+
+AC_PATH_PROG(MV,[mv],[false])
+if test ${MV} = "false"
+then
+       AC_MSG_ERROR([mv required but not found])
+fi
+
+AC_PATH_PROG(DOT,[dot],[false])
+
+AC_PATH_PROG(ETAGS,[etags],[false])
+
+AC_PATH_PROG(PYTHON,[python],[false])
+if test ${PYTHON} = "false"
+then
+       AC_MSG_WARN([python required but not found])
+fi
+
+AC_PATH_PROG(QMTEST,[qmtest],[false])
+if test ${QMTEST} = "false"
+then
+       AC_MSG_WARN([qmtest required but not found])
+fi
 
 dnl Verify that the version of python available is high enough for qmtest
 pyversion=`$PYTHON -V 2>&1 | cut -d\  -f2`
@@ -316,11 +271,11 @@ then
        then
                if test "$pyminor" -lt "2"
                then
-                       AC_MSG_ERROR([Python 2.2 or greater required])
+                       AC_MSG_WARN([Python 2.2 or greater required for qmtest])
                fi
        fi
 else
-       AC_MSG_ERROR([Python 2.2 or greater required])
+       AC_MSG_WARN([Python 2.2 or greater required for qmtest])
 fi
 
 dnl Verify that the source directory is valid
@@ -333,11 +288,15 @@ dnl **************************************************************************
 dnl libelf is for sparc only; we can ignore it if we don't have it
 AC_CHECK_LIB(elf, elf_begin)
 
-dnl dlopen() is required.  If we don't find it, quit.
-AC_SEARCH_LIBS(dlopen,dl,,AC_MSG_ERROR([dlopen() required but not found]))
+dnl dlopen() is required for plugin support.
+AC_SEARCH_LIBS(dlopen,dl,AC_DEFINE([HAVE_DLOPEN],[1],[Define if dlopen() is available on this platform.]),AC_MSG_WARN([dlopen() not found - disabling plugin support]))
 
 dnl mallinfo is optional; the code can compile (minus features) without it
-AC_SEARCH_LIBS(mallinfo,malloc,AC_DEFINE([HAVE_MALLINFO],[1]))
+AC_SEARCH_LIBS(mallinfo,malloc,AC_DEFINE([HAVE_MALLINFO],[1],[Define if mallinfo() is available on this platform.]))
+
+dnl pthread locking functions are optional - but llvm will not be thread-safe
+dnl without locks.
+AC_SEARCH_LIBS(pthread_mutex_lock,pthread,AC_DEFINE(HAVE_PTHREAD_MUTEX_LOCK,1,[Define if PThread mutexes (e.g., pthread_mutex_lock) are available in the system's thread library.]))
 
 dnl
 dnl The math libraries are used by the test code, but not by the actual LLVM
@@ -362,7 +321,7 @@ dnl Check for ANSI C/POSIX header files
 AC_CHECK_HEADERS(assert.h fcntl.h limits.h sys/time.h unistd.h errno.h signal.h math.h)
 
 dnl Check for system specific header files
-AC_CHECK_HEADERS(malloc.h strings.h sys/mman.h sys/resource.h)
+AC_CHECK_HEADERS(malloc.h sys/mman.h sys/resource.h)
 
 dnl Check for header files associated with dlopen and friends
 AC_CHECK_HEADERS(dlfcn.h link.h)
@@ -376,7 +335,7 @@ AC_C_CONST
 AC_C_INLINE
 
 dnl Check for machine endian-ness
-AC_C_BIGENDIAN(AC_DEFINE([ENDIAN_BIG]),AC_DEFINE(ENDIAN_LITTLE))
+AC_C_BIGENDIAN(AC_DEFINE([ENDIAN_BIG],[],[Define if the machine is Big-Endian]),AC_DEFINE([ENDIAN_LITTLE],[],[Define if the machine is Little-Endian]))
 
 dnl Check for types
 AC_TYPE_PID_T
@@ -386,9 +345,12 @@ AC_CHECK_TYPES([uint64_t],,AC_MSG_ERROR([Type uint64_t required but not found]))
 AC_HEADER_TIME
 AC_STRUCT_TM
 
+dnl Check for various C features
+AC_C_PRINTF_A
+
 dnl Check for C++ extensions
-AC_CXX_HAVE_EXT_HASH_MAP
-AC_CXX_HAVE_EXT_HASH_SET
+AC_CXX_HAVE_HASH_MAP
+AC_CXX_HAVE_HASH_SET
 AC_CXX_HAVE_EXT_SLIST
 AC_CXX_HAVE_STD_ITERATOR
 AC_CXX_HAVE_BI_ITERATOR
@@ -408,7 +370,7 @@ then
 fi
 AC_HEADER_MMAP_ANONYMOUS
 AC_TYPE_SIGNAL
-AC_CHECK_FUNCS(getcwd gettimeofday strcspn strdup strerror strspn strstr strtod strtol)
+AC_CHECK_FUNCS(getcwd gettimeofday strcspn strdup strerror strspn strstr strtod strtol strtoq strtoll)
 
 dnl
 dnl Need to check mmap for MAP_PRIVATE, MAP_ANONYMOUS, MAP_ANON, MAP_FIXED
@@ -425,6 +387,9 @@ dnl these checks should go away.
 AC_CHECK_FUNC(mmap,,AC_MSG_ERROR([Function mmap() required but not found]))
 AC_CHECK_FUNC(mprotect,,AC_MSG_ERROR([Function mprotect() required but not found]))
 
+dnl Determine if the linker supports the -R option.
+AC_LINK_USE_R()
+
 dnl **************************************************************************
 dnl * Enable various compile-time options
 dnl **************************************************************************
@@ -448,11 +413,24 @@ else
 fi
 
 dnl Spec Benchmarks
-AC_ARG_ENABLE(spec,AC_HELP_STRING([--enable-spec],[Compile SPEC benchmarks (default is NO)]),,enableval=no)
+AC_ARG_ENABLE(spec2000,AC_HELP_STRING([--enable-spec2000],[Compile SPEC 2000 benchmarks (default is NO)]),,enableval=no)
 if test ${enableval} = "no"
 then
-       AC_SUBST(USE_SPEC,[[]])
+       if test -d /home/vadve/shared/benchmarks/speccpu2000/benchspec
+       then
+               AC_SUBST(SPEC_ROOT,[/home/vadve/shared/benchmarks/speccpu2000/benchspec])
+               AC_SUBST(USE_SPEC,[[USE_SPEC=1]])
+       else
+               AC_SUBST(USE_SPEC,[[]])
+               AC_SUBST(SPEC_ROOT,[])
+       fi
 else
+       if test ${enableval} = ""
+       then
+               AC_SUBST(SPEC_ROOT,[/home/vadve/shared/benchmarks/speccpu2000/benchspec])
+       else
+               AC_SUBST(SPEC_ROOT,[${enableval}])
+       fi
        AC_SUBST(USE_SPEC,[[USE_SPEC=1]])
 fi
 
@@ -499,12 +477,43 @@ dnl **************************************************************************
 dnl * Set the location of various third-party software packages
 dnl **************************************************************************
 
-dnl Location of SPEC benchmarks
-AC_ARG_WITH(spec,AC_HELP_STRING([--with-spec],[Location of SPEC benchmarks]),AC_SUBST(SPEC_ROOT,[$withval]),AC_SUBST(SPEC_ROOT,[/home/vadve/shared/benchmarks/speccpu2000/benchspec]))
-
 dnl Location of the LLVM C front end
 AC_ARG_WITH(llvmgccdir,AC_HELP_STRING([--with-llvmgccdir],[Location of LLVM GCC front-end]),AC_SUBST(LLVMGCCDIR,[$withval]))
 
+AC_MSG_CHECKING([for llvm-gcc])
+LLVM_GCC_CHECK=no
+if test -d "$LLVMGCCDIR"
+then
+       if test -x "$LLVMGCCDIR/bin/gcc"
+       then
+               LLVM_GCC_CHECK="$LLVMGCCDIR/bin/gcc"
+       fi
+fi
+llvmgccwarn=no
+AC_MSG_RESULT($LLVM_GCC_CHECK)
+if test "$LLVM_GCC_CHECK" = "no"
+then
+    llvmgccwarn=yes
+fi
+
+AC_MSG_CHECKING([whether llvm-gcc is sane])
+LLVM_GCC_SANE=no
+if test -x "$LLVM_GCC_CHECK"
+then
+       cp /dev/null conftest.c
+    "$LLVM_GCC_CHECK" -S -o - conftest.c | grep implementation > /dev/null 2>&1
+       if test $? -eq 0
+       then
+               LLVM_GCC_SANE=yes
+       fi
+       rm conftest.c
+fi
+AC_MSG_RESULT($LLVM_GCC_SANE)
+if test "$LLVM_GCC_SANE" = "no"
+then
+       llvmgccwarn=yes
+fi
+
 dnl Location of the bytecode repository
 AC_ARG_WITH(bcrepos,AC_HELP_STRING([--with-bcrepos],[Location of Bytecode Repository]),AC_SUBST(BCR,[$withval]),AC_SUBST(BCR,[/home/vadve/lattner/LLVMPrograms]))
 
@@ -522,3 +531,13 @@ dnl **************************************************************************
 dnl * Create the output files
 dnl **************************************************************************
 AC_OUTPUT(Makefile.config)
+
+if test $llvmgccwarn = yes
+then
+       AC_MSG_WARN([***** llvm C/C++ front end was not found, or does not])
+       AC_MSG_WARN([***** appear to be working.])
+       AC_MSG_WARN([***** ])
+       AC_MSG_WARN([***** Please check configure's --with-llvmgccdir option.])
+       AC_MSG_WARN([***** Runtime libraries (in llvm/runtime) will not be built,])
+       AC_MSG_WARN([***** but you should be able to build the llvm tools.])
+fi