Added the eon and perlbmk benchmarks.
[oota-llvm.git] / autoconf / configure.ac
index dd180c89672a3d5f78e388ff3edf862b52ad2b8b..c7d21a796e9fddcb0ed745f0afbdf4182f988540 100644 (file)
@@ -35,6 +35,11 @@ then
   AC_CONFIG_SUBDIRS(projects/reopt)
 fi
 
+if test -d ${srcdir}/projects/poolalloc
+then
+  AC_CONFIG_SUBDIRS(projects/poolalloc)
+fi
+
 dnl Configure a header file
 AC_CONFIG_HEADERS(include/Config/config.h)
 AC_CONFIG_MAKEFILE(Makefile)
@@ -59,6 +64,7 @@ AC_CONFIG_MAKEFILE(lib/CodeGen/SelectionDAG/Makefile)
 AC_CONFIG_MAKEFILE(lib/ExecutionEngine/Makefile)
 AC_CONFIG_MAKEFILE(lib/ExecutionEngine/Interpreter/Makefile)
 AC_CONFIG_MAKEFILE(lib/ExecutionEngine/JIT/Makefile)
+AC_CONFIG_MAKEFILE(lib/Support/Makefile)
 AC_CONFIG_MAKEFILE(lib/Target/Makefile)
 AC_CONFIG_MAKEFILE(lib/Target/Sparc/Makefile)
 AC_CONFIG_MAKEFILE(lib/Target/X86/Makefile)
@@ -87,7 +93,8 @@ AC_CONFIG_MAKEFILE(runtime/libdummy/Makefile)
 AC_CONFIG_MAKEFILE(runtime/libtrace/Makefile)
 AC_CONFIG_MAKEFILE(test/Makefile)
 AC_CONFIG_MAKEFILE(test/Makefile.tests)
-AC_CONFIG_MAKEFILE(test/QMTestDB/QMTest/llvm.py)
+AC_CONFIG_MAKEFILE(test/QMTest/llvm.py)
+AC_CONFIG_MAKEFILE(test/QMTest/llvmdb.py)
 AC_CONFIG_MAKEFILE(test/Programs/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/Makefile.programs)
 AC_CONFIG_MAKEFILE(test/Programs/TEST.aa.Makefile)
@@ -108,6 +115,7 @@ AC_CONFIG_MAKEFILE(test/Programs/External/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/Makefile.spec)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CFP2000/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CFP2000/177.mesa/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CFP2000/179.art/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CFP2000/183.equake/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CFP2000/188.ammp/Makefile)
@@ -118,6 +126,8 @@ AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/176.gcc/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/181.mcf/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/186.crafty/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/197.parser/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/252.eon/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/253.perlbmk/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/254.gap/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/255.vortex/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/External/SPEC/CINT2000/256.bzip2/Makefile)
@@ -162,12 +172,6 @@ AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Ptrdist/ks/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/Ptrdist/yacr2/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/llubenchmark/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/MultiSource/Benchmarks/sim/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Flex/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Larn/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Moria-5.5.2/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/Povray31/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/NoSource/m4/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Makefile.singlesrc)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Gizmos/Makefile)
@@ -183,7 +187,6 @@ AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C++/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C++/EH/Makefile)
-AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C++/CompileFail/Makefile)
 AC_CONFIG_MAKEFILE(tools/Makefile)
 AC_CONFIG_MAKEFILE(tools/analyze/Makefile)
 AC_CONFIG_MAKEFILE(tools/bugpoint/Makefile)
@@ -198,7 +201,10 @@ AC_CONFIG_MAKEFILE(tools/llvm-as/Makefile)
 AC_CONFIG_MAKEFILE(tools/llvm-dis/Makefile)
 AC_CONFIG_MAKEFILE(tools/llvm-link/Makefile)
 AC_CONFIG_MAKEFILE(tools/opt/Makefile)
-AC_CONFIG_MAKEFILE(www/docs/Makefile)
+AC_CONFIG_MAKEFILE(utils/Makefile)
+AC_CONFIG_MAKEFILE(utils/Burg/Makefile)
+AC_CONFIG_MAKEFILE(utils/Burg/Doc/Makefile)
+AC_CONFIG_MAKEFILE(utils/TableGen/Makefile)
 AC_CONFIG_MAKEFILE(projects/Makefile)
 AC_CONFIG_MAKEFILE(projects/sample/Makefile)
 AC_CONFIG_MAKEFILE(projects/sample/Makefile.common)
@@ -211,13 +217,6 @@ AC_CONFIG_MAKEFILE(projects/ModuleMaker/Makefile)
 AC_CONFIG_MAKEFILE(projects/ModuleMaker/Makefile.common)
 AC_CONFIG_MAKEFILE(projects/ModuleMaker/tools/Makefile)
 AC_CONFIG_MAKEFILE(projects/ModuleMaker/tools/ModuleMaker/Makefile)
-AC_CONFIG_MAKEFILE(support/Makefile)
-AC_CONFIG_MAKEFILE(support/lib/Makefile)
-AC_CONFIG_MAKEFILE(support/lib/Support/Makefile)
-AC_CONFIG_MAKEFILE(support/tools/Makefile)
-AC_CONFIG_MAKEFILE(support/tools/Burg/Makefile)
-AC_CONFIG_MAKEFILE(support/tools/Burg/Doc/Makefile)
-AC_CONFIG_MAKEFILE(support/tools/TableGen/Makefile)
 
 dnl **************************************************************************
 dnl * Determine which system we are building on
@@ -363,8 +362,6 @@ AC_PATH_PROG(DOT,[dot],[false])
 
 AC_PATH_PROG(ETAGS,[etags],[false])
 
-AC_PATH_PROG(PURIFY,[purify],[false])
-
 AC_PATH_PROG(PYTHON,[python],[false])
 if test ${PYTHON} = "false"
 then
@@ -405,11 +402,11 @@ dnl **************************************************************************
 dnl libelf is for sparc only; we can ignore it if we don't have it
 AC_CHECK_LIB(elf, elf_begin)
 
-dnl dlopen() is required.  If we don't find it, quit.
-AC_SEARCH_LIBS(dlopen,dl,,AC_MSG_ERROR([dlopen() required but not found]))
+dnl dlopen() is required for plugin support.
+AC_SEARCH_LIBS(dlopen,dl,AC_DEFINE([HAVE_DLOPEN],[1],[Define if dlopen() is available on this platform.]),AC_MSG_WARN([dlopen() not found - disabling plugin support]))
 
 dnl mallinfo is optional; the code can compile (minus features) without it
-AC_SEARCH_LIBS(mallinfo,malloc,AC_DEFINE([HAVE_MALLINFO],[1]))
+AC_SEARCH_LIBS(mallinfo,malloc,AC_DEFINE([HAVE_MALLINFO],[1],[Define if mallinfo() is available on this platform.]))
 
 dnl
 dnl The math libraries are used by the test code, but not by the actual LLVM
@@ -448,7 +445,7 @@ AC_C_CONST
 AC_C_INLINE
 
 dnl Check for machine endian-ness
-AC_C_BIGENDIAN(AC_DEFINE([ENDIAN_BIG]),AC_DEFINE(ENDIAN_LITTLE))
+AC_C_BIGENDIAN(AC_DEFINE([ENDIAN_BIG],[],[Define if the machine is Big-Endian]),AC_DEFINE([ENDIAN_LITTLE],[],[Define if the machine is Little-Endian]))
 
 dnl Check for types
 AC_TYPE_PID_T
@@ -480,7 +477,11 @@ then
 fi
 AC_HEADER_MMAP_ANONYMOUS
 AC_TYPE_SIGNAL
-AC_CHECK_FUNCS(getcwd gettimeofday strcspn strdup strerror strspn strstr strtod strtol)
+AC_CHECK_FUNCS(getcwd gettimeofday strcspn strdup strerror strspn strstr strtod strtol strtoq strtoll strsignal)
+AC_CHECK_DECLS([sys_siglist],[],[],[
+#if HAVE_SIGNAL_H
+#include <signal.h>
+#endif])
 
 dnl
 dnl Need to check mmap for MAP_PRIVATE, MAP_ANONYMOUS, MAP_ANON, MAP_FIXED
@@ -520,11 +521,24 @@ else
 fi
 
 dnl Spec Benchmarks
-AC_ARG_ENABLE(spec,AC_HELP_STRING([--enable-spec],[Compile SPEC benchmarks (default is NO)]),,enableval=no)
+AC_ARG_ENABLE(spec2000,AC_HELP_STRING([--enable-spec],[Compile SPEC 2000 benchmarks (default is NO)]),,enableval=no)
 if test ${enableval} = "no"
 then
-       AC_SUBST(USE_SPEC,[[]])
+       if test -d /home/vadve/shared/benchmarks/speccpu2000/benchspec
+       then
+               AC_SUBST(SPEC_ROOT,[/home/vadve/shared/benchmarks/speccpu2000/benchspec])
+               AC_SUBST(USE_SPEC,[[USE_SPEC=1]])
+       else
+               AC_SUBST(USE_SPEC,[[]])
+               AC_SUBST(SPEC_ROOT,[])
+       fi
 else
+       if test ${enableval} = ""
+       then
+               AC_SUBST(SPEC_ROOT,[/home/vadve/shared/benchmarks/speccpu2000/benchspec])
+       else
+               AC_SUBST(SPEC_ROOT,[${enableval}])
+       fi
        AC_SUBST(USE_SPEC,[[USE_SPEC=1]])
 fi
 
@@ -571,9 +585,6 @@ dnl **************************************************************************
 dnl * Set the location of various third-party software packages
 dnl **************************************************************************
 
-dnl Location of SPEC benchmarks
-AC_ARG_WITH(spec,AC_HELP_STRING([--with-spec],[Location of SPEC benchmarks]),AC_SUBST(SPEC_ROOT,[$withval]),AC_SUBST(SPEC_ROOT,[/home/vadve/shared/benchmarks/speccpu2000/benchspec]))
-
 dnl Location of the LLVM C front end
 AC_ARG_WITH(llvmgccdir,AC_HELP_STRING([--with-llvmgccdir],[Location of LLVM GCC front-end]),AC_SUBST(LLVMGCCDIR,[$withval]))