Removed Makefile for CompileFail tests. They are now run by QMTest and are
[oota-llvm.git] / autoconf / configure.ac
index 07986edfe08ca6743270ea758f0e7cb5da1d7f9b..a3554377b71507274b23aeb1d84c3efc1a269560 100644 (file)
@@ -30,6 +30,16 @@ then
        fi
 fi
 
+if test -d ${srcdir}/projects/reopt
+then
+  AC_CONFIG_SUBDIRS(projects/reopt)
+fi
+
+if test -d ${srcdir}/projects/poolalloc
+then
+  AC_CONFIG_SUBDIRS(projects/poolalloc)
+fi
+
 dnl Configure a header file
 AC_CONFIG_HEADERS(include/Config/config.h)
 AC_CONFIG_MAKEFILE(Makefile)
@@ -54,7 +64,6 @@ AC_CONFIG_MAKEFILE(lib/CodeGen/SelectionDAG/Makefile)
 AC_CONFIG_MAKEFILE(lib/ExecutionEngine/Makefile)
 AC_CONFIG_MAKEFILE(lib/ExecutionEngine/Interpreter/Makefile)
 AC_CONFIG_MAKEFILE(lib/ExecutionEngine/JIT/Makefile)
-AC_CONFIG_MAKEFILE(lib/Support/Makefile)
 AC_CONFIG_MAKEFILE(lib/Target/Makefile)
 AC_CONFIG_MAKEFILE(lib/Target/Sparc/Makefile)
 AC_CONFIG_MAKEFILE(lib/Target/X86/Makefile)
@@ -175,6 +184,10 @@ AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Benchmarks/Misc/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/CustomChecked/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/UnitTests/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/UnitTests/SetjmpLongjmp/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C++/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C++/EH/Makefile)
 AC_CONFIG_MAKEFILE(tools/Makefile)
 AC_CONFIG_MAKEFILE(tools/analyze/Makefile)
 AC_CONFIG_MAKEFILE(tools/bugpoint/Makefile)
@@ -189,10 +202,6 @@ AC_CONFIG_MAKEFILE(tools/llvm-as/Makefile)
 AC_CONFIG_MAKEFILE(tools/llvm-dis/Makefile)
 AC_CONFIG_MAKEFILE(tools/llvm-link/Makefile)
 AC_CONFIG_MAKEFILE(tools/opt/Makefile)
-AC_CONFIG_MAKEFILE(utils/Makefile)
-AC_CONFIG_MAKEFILE(utils/Burg/Makefile)
-AC_CONFIG_MAKEFILE(utils/Burg/Doc/Makefile)
-AC_CONFIG_MAKEFILE(utils/TableGen/Makefile)
 AC_CONFIG_MAKEFILE(www/docs/Makefile)
 AC_CONFIG_MAKEFILE(projects/Makefile)
 AC_CONFIG_MAKEFILE(projects/sample/Makefile)
@@ -206,6 +215,13 @@ AC_CONFIG_MAKEFILE(projects/ModuleMaker/Makefile)
 AC_CONFIG_MAKEFILE(projects/ModuleMaker/Makefile.common)
 AC_CONFIG_MAKEFILE(projects/ModuleMaker/tools/Makefile)
 AC_CONFIG_MAKEFILE(projects/ModuleMaker/tools/ModuleMaker/Makefile)
+AC_CONFIG_MAKEFILE(support/Makefile)
+AC_CONFIG_MAKEFILE(support/lib/Makefile)
+AC_CONFIG_MAKEFILE(support/lib/Support/Makefile)
+AC_CONFIG_MAKEFILE(support/tools/Makefile)
+AC_CONFIG_MAKEFILE(support/tools/Burg/Makefile)
+AC_CONFIG_MAKEFILE(support/tools/Burg/Doc/Makefile)
+AC_CONFIG_MAKEFILE(support/tools/TableGen/Makefile)
 
 dnl **************************************************************************
 dnl * Determine which system we are building on