configure: Don't require a perl interpreter to be present, LLVM's buildsystem doesn...
[oota-llvm.git] / autoconf / configure.ac
index e18725d9740446b7615f2ae941d227007bf20af1..5ea2e306a5c99d50d546dcc3099894d7132f8ead 100644 (file)
@@ -1005,16 +1005,6 @@ if test "$XDOT_PY" != "echo xdot.py" ; then
    [Define to path to xdot.py program if found or 'echo xdot.py' otherwise])
 fi
 
-dnl Look for a sufficiently recent version of Perl.
-LLVM_PROG_PERL([5.006])
-AC_SUBST(PERL)
-if test x"$PERL" = xnone; then
-   AC_SUBST(HAVE_PERL,0)
-   AC_MSG_ERROR([perl is required but was not found, please install it])
-else
-   AC_SUBST(HAVE_PERL,1)
-fi
-
 dnl Find the install program
 AC_PROG_INSTALL
 dnl Prepend src dir to install path dir if it's a relative path