Link with -rdynamic instead of -Wl,-export-dynamic.
[oota-llvm.git] / autoconf / configure.ac
index 97a14293ea8553e1c8b9f714941bb8fd92f82ede..5be25af2adf2a2d7b98779b6fb41fca9a8ca7bb3 100644 (file)
@@ -1239,7 +1239,7 @@ AC_LINK_GET_VERSION
 dnl Determine whether the linker supports the -R option.
 AC_LINK_USE_R
 
-dnl Determine whether the linker supports the -export-dynamic option.
+dnl Determine whether the compiler supports the -rdynamic option.
 AC_LINK_EXPORT_DYNAMIC
 
 dnl Determine whether the linker supports the --version-script option.
@@ -1863,7 +1863,7 @@ AC_SUBST(RPATH)
 
 dnl Determine linker rdynamic flag
 if test "$llvm_cv_link_use_export_dynamic" = "yes" ; then
-  RDYNAMIC="-Wl,-export-dynamic"
+  RDYNAMIC="-rdynamic"
 else
   RDYNAMIC=""
 fi