Pass CPPFLAGS/CFLAGS/CXXFLAGS from the environment of configure to
[oota-llvm.git] / autoconf / configure.ac
index 4ca4eb9042d498643b45dbb2918305a53b9d01a6..4c3af79edcd824d9b52374b0fee457d1ddacbb7b 100644 (file)
@@ -59,6 +59,11 @@ if test ${srcdir} != "." ; then
   fi
 fi
 
+dnl Default to empty (i.e. assigning the null string to) CFLAGS and CXXFLAGS,
+dnl instead of the autoconf default (for example, '-g -O2' for CC=gcc).
+${CFLAGS=}
+${CXXFLAGS=}
+
 dnl We need to check for the compiler up here to avoid anything else
 dnl starting with a different one.
 AC_PROG_CC(clang llvm-gcc gcc)