Fix the --with-extra-options to use the correct variable.
[oota-llvm.git] / autoconf / configure.ac
index 6d1624491d0ed3c766f2f2aadf7ffcdf681076fb..4526c48dbe84875419a4d605a40791868536a076 100644 (file)
@@ -337,10 +337,10 @@ dnl Specify extra build options
 AC_ARG_WITH(extra-options,
   AS_HELP_STRING([--with-extra-options],
                  [Specify addtional options to compile LLVM with]),,
-                 extraopts=default)
-case "$extraopts" in
+                 withval=default)
+case "$withval" in
   default) EXTRA_OPTIONS= ;;
-  *) EXTRA_OPTIONS=$extraopts ;;
+  *) EXTRA_OPTIONS=$withval ;;
 esac
 AC_SUBST(EXTRA_OPTIONS,$EXTRA_OPTIONS)