reverting previous change, will add support for other compilers later
[oota-llvm.git] / autoconf / configure.ac
index 189503923468458ed2c8b3fdab03e41011b1e1ec..3f51f2d103ebac40912e2131dad8ceff5726a4b2 100644 (file)
@@ -412,6 +412,17 @@ case $CC in
     ;;
 esac
 
+if test "$GCC" != "yes" && test "$ICC" != "yes"
+then
+  AC_MSG_ERROR([gcc|icc required but not found])
+fi
+
+dnl Ensure that compilation tools are GCC; we use GCC specific extensions
+if test "$GXX" != "yes" && test "$IXX" != "yes"
+then
+  AC_MSG_ERROR([g++|icc required but not found])
+fi
+
 dnl Verify that GCC is version 3.0 or higher
 if test "$GCC" = "yes"
 then