Renamed -use-spec to -use-spec2000.
[oota-llvm.git] / autoconf / configure.ac
index 1c965c28911d4d9a8f7b68618c467b78255c0ce2..3df9b9b4a7566a3ead9663b14c78cdd56b662fd5 100644 (file)
@@ -30,6 +30,16 @@ then
        fi
 fi
 
+if test -d ${srcdir}/projects/reopt
+then
+  AC_CONFIG_SUBDIRS(projects/reopt)
+fi
+
+if test -d ${srcdir}/projects/poolalloc
+then
+  AC_CONFIG_SUBDIRS(projects/poolalloc)
+fi
+
 dnl Configure a header file
 AC_CONFIG_HEADERS(include/Config/config.h)
 AC_CONFIG_MAKEFILE(Makefile)
@@ -83,7 +93,8 @@ AC_CONFIG_MAKEFILE(runtime/libdummy/Makefile)
 AC_CONFIG_MAKEFILE(runtime/libtrace/Makefile)
 AC_CONFIG_MAKEFILE(test/Makefile)
 AC_CONFIG_MAKEFILE(test/Makefile.tests)
-AC_CONFIG_MAKEFILE(test/QMTestDB/QMTest/llvm.py)
+AC_CONFIG_MAKEFILE(test/QMTest/llvm.py)
+AC_CONFIG_MAKEFILE(test/QMTest/llvmdb.py)
 AC_CONFIG_MAKEFILE(test/Programs/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/Makefile.programs)
 AC_CONFIG_MAKEFILE(test/Programs/TEST.aa.Makefile)
@@ -175,6 +186,10 @@ AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Benchmarks/Misc/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/CustomChecked/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/UnitTests/Makefile)
 AC_CONFIG_MAKEFILE(test/Programs/SingleSource/UnitTests/SetjmpLongjmp/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C++/Makefile)
+AC_CONFIG_MAKEFILE(test/Programs/SingleSource/Regression/C++/EH/Makefile)
 AC_CONFIG_MAKEFILE(tools/Makefile)
 AC_CONFIG_MAKEFILE(tools/analyze/Makefile)
 AC_CONFIG_MAKEFILE(tools/bugpoint/Makefile)
@@ -351,18 +366,16 @@ AC_PATH_PROG(DOT,[dot],[false])
 
 AC_PATH_PROG(ETAGS,[etags],[false])
 
-AC_PATH_PROG(PURIFY,[purify],[false])
-
 AC_PATH_PROG(PYTHON,[python],[false])
 if test ${PYTHON} = "false"
 then
-       AC_MSG_ERROR([python required but not found])
+       AC_MSG_WARN([python required but not found])
 fi
 
 AC_PATH_PROG(QMTEST,[qmtest],[false])
 if test ${QMTEST} = "false"
 then
-       AC_MSG_ERROR([qmtest required but not found])
+       AC_MSG_WARN([qmtest required but not found])
 fi
 
 dnl Verify that the version of python available is high enough for qmtest
@@ -393,8 +406,8 @@ dnl **************************************************************************
 dnl libelf is for sparc only; we can ignore it if we don't have it
 AC_CHECK_LIB(elf, elf_begin)
 
-dnl dlopen() is required.  If we don't find it, quit.
-AC_SEARCH_LIBS(dlopen,dl,,AC_MSG_ERROR([dlopen() required but not found]))
+dnl dlopen() is required for plugin support.
+AC_SEARCH_LIBS(dlopen,dl,AC_DEFINE([HAVE_DLOPEN],[1]),AC_MSG_WARN([dlopen() not found - disabling plugin support]))
 
 dnl mallinfo is optional; the code can compile (minus features) without it
 AC_SEARCH_LIBS(mallinfo,malloc,AC_DEFINE([HAVE_MALLINFO],[1]))
@@ -468,7 +481,7 @@ then
 fi
 AC_HEADER_MMAP_ANONYMOUS
 AC_TYPE_SIGNAL
-AC_CHECK_FUNCS(getcwd gettimeofday strcspn strdup strerror strspn strstr strtod strtol)
+AC_CHECK_FUNCS(getcwd gettimeofday strcspn strdup strerror strspn strstr strtod strtol strtoq strtoll)
 
 dnl
 dnl Need to check mmap for MAP_PRIVATE, MAP_ANONYMOUS, MAP_ANON, MAP_FIXED
@@ -508,11 +521,24 @@ else
 fi
 
 dnl Spec Benchmarks
-AC_ARG_ENABLE(spec,AC_HELP_STRING([--enable-spec],[Compile SPEC benchmarks (default is NO)]),,enableval=no)
+AC_ARG_ENABLE(spec2000,AC_HELP_STRING([--enable-spec],[Compile SPEC 2000 benchmarks (default is NO)]),,enableval=no)
 if test ${enableval} = "no"
 then
-       AC_SUBST(USE_SPEC,[[]])
+       if test -d /home/vadve/shared/benchmarks/speccpu2000/benchspec
+       then
+               AC_SUBST(SPEC_ROOT,[/home/vadve/shared/benchmarks/speccpu2000/benchspec])
+               AC_SUBST(USE_SPEC,[[USE_SPEC=1]])
+       else
+               AC_SUBST(USE_SPEC,[[]])
+               AC_SUBST(SPEC_ROOT,[])
+       fi
 else
+       if test ${enableval} = ""
+       then
+               AC_SUBST(SPEC_ROOT,[/home/vadve/shared/benchmarks/speccpu2000/benchspec])
+       else
+               AC_SUBST(SPEC_ROOT,[${enableval}])
+       fi
        AC_SUBST(USE_SPEC,[[USE_SPEC=1]])
 fi
 
@@ -559,9 +585,6 @@ dnl **************************************************************************
 dnl * Set the location of various third-party software packages
 dnl **************************************************************************
 
-dnl Location of SPEC benchmarks
-AC_ARG_WITH(spec,AC_HELP_STRING([--with-spec],[Location of SPEC benchmarks]),AC_SUBST(SPEC_ROOT,[$withval]),AC_SUBST(SPEC_ROOT,[/home/vadve/shared/benchmarks/speccpu2000/benchspec]))
-
 dnl Location of the LLVM C front end
 AC_ARG_WITH(llvmgccdir,AC_HELP_STRING([--with-llvmgccdir],[Location of LLVM GCC front-end]),AC_SUBST(LLVMGCCDIR,[$withval]))