SSL cleanup: moving some OpenSSL definitions to new dir folly/io/async/ssl
[folly.git] / folly / Makefile.am
index 65408068567b3e18f240171390de8694c5748a5e..3f443eeceb3f473eed3418ee155a9e25b93eb4c1 100644 (file)
@@ -34,7 +34,6 @@ nobase_follyinclude_HEADERS = \
        AtomicLinkedList.h \
        AtomicStruct.h \
        AtomicUnorderedMap.h \
-       CppAttributes.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
@@ -42,8 +41,10 @@ nobase_follyinclude_HEADERS = \
        Checksum.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
+       ConditionallyExistent.h \
        ContainerTraits.h \
        Conv.h \
+       CppAttributes.h \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
@@ -69,6 +70,7 @@ nobase_follyinclude_HEADERS = \
        detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SpinLockImpl.h \
+       detail/StaticSingletonManager.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
        detail/TurnSequencer.h \
@@ -138,7 +140,6 @@ nobase_follyinclude_HEADERS = \
        experimental/TestUtil.h \
        experimental/TLRefCount.h \
        experimental/TupleOps.h \
-       SparseByteSet.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -195,6 +196,7 @@ nobase_follyinclude_HEADERS = \
        IPAddressV4.h \
        IPAddressV6.h \
        IPAddressException.h \
+       Indestructible.h \
        IndexedMemPool.h \
        init/Init.h \
        IntrusiveList.h \
@@ -227,7 +229,9 @@ nobase_follyinclude_HEADERS = \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
-       io/async/OpenSSLPtrTypes.h \
+       io/async/ssl/OpenSSLPtrTypes.h \
+       io/async/ssl/OpenSSLUtils.h \
+       io/async/ssl/TLSDefinitions.h \
        io/async/Request.h \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
@@ -255,6 +259,7 @@ nobase_follyinclude_HEADERS = \
        Memory.h \
        MemoryMapping.h \
        MicroSpinLock.h \
+       MicroLock.h \
        MoveWrapper.h \
        MPMCPipeline.h \
        MPMCQueue.h \
@@ -263,9 +268,17 @@ nobase_follyinclude_HEADERS = \
        Padded.h \
        PicoSpinLock.h \
        Portability.h \
+       portability/Constexpr.h \
+       portability/Environment.h \
+       portability/GFlags.h \
+       portability/Stdlib.h \
+       portability/Strings.h \
        portability/Syscall.h \
+       portability/SysTime.h \
+       portability/SysTypes.h \
        portability/SysUio.h \
-       ConditionallyExistent.h \
+       portability/Time.h \
+       portability/Windows.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -281,6 +294,7 @@ nobase_follyinclude_HEADERS = \
        small_vector.h \
        SocketAddress.h \
        sorted_vector_types.h \
+       SparseByteSet.h \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
@@ -355,6 +369,7 @@ libfolly_la_SOURCES = \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        detail/Futex.cpp \
+       detail/StaticSingletonManager.cpp \
        detail/ThreadLocalDetail.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
@@ -378,18 +393,26 @@ libfolly_la_SOURCES = \
        io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
+       io/async/Request.cpp \
        io/async/SSLContext.cpp \
        io/async/ScopedEventBaseThread.cpp \
        io/async/HHWheelTimer.cpp \
        io/async/test/SocketPair.cpp \
        io/async/test/TimeUtil.cpp \
+       io/async/ssl/OpenSSLUtils.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
+       portability/Environment.cpp \
+       portability/Stdlib.cpp \
+       portability/Strings.cpp \
+       portability/SysTime.cpp \
+       portability/Time.cpp \
        Random.cpp \
        SafeAssert.cpp \
        SharedMutex.cpp \
+       MicroLock.cpp \
        Singleton.cpp \
        SocketAddress.cpp \
        SpookyHashV1.cpp \