SSL cleanup: moving some OpenSSL definitions to new dir folly/io/async/ssl
[folly.git] / folly / Makefile.am
index 3772e600b2c655352e44d7712b6190b68778a60c..3f443eeceb3f473eed3418ee155a9e25b93eb4c1 100644 (file)
@@ -229,7 +229,9 @@ nobase_follyinclude_HEADERS = \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
-       io/async/OpenSSLPtrTypes.h \
+       io/async/ssl/OpenSSLPtrTypes.h \
+       io/async/ssl/OpenSSLUtils.h \
+       io/async/ssl/TLSDefinitions.h \
        io/async/Request.h \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
@@ -273,8 +275,10 @@ nobase_follyinclude_HEADERS = \
        portability/Strings.h \
        portability/Syscall.h \
        portability/SysTime.h \
+       portability/SysTypes.h \
        portability/SysUio.h \
        portability/Time.h \
+       portability/Windows.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -395,6 +399,7 @@ libfolly_la_SOURCES = \
        io/async/HHWheelTimer.cpp \
        io/async/test/SocketPair.cpp \
        io/async/test/TimeUtil.cpp \
+       io/async/ssl/OpenSSLUtils.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        MacAddress.cpp \