Move all of the GoogleTest files back to the same locations they occupy
[oota-llvm.git] / utils / unittest / CMakeLists.txt
index 8bdfee15c198e80bb6dbb901855004a4a8f118f9..fd1a048d832b37c9ef2b8c69960b9a1391b7e27f 100644 (file)
@@ -14,6 +14,7 @@
 # Where gtest's .h files can be found.
 include_directories(
   googletest/include
+  googletest
   )
 
 if(WIN32)
@@ -38,13 +39,7 @@ if(MSVC AND MSVC_VERSION EQUAL 1700)
 endif ()
 
 add_llvm_library(gtest
-  googletest/gtest.cc
-  googletest/gtest-death-test.cc
-  googletest/gtest-filepath.cc
-  googletest/gtest-port.cc
-  googletest/gtest-printers.cc
-  googletest/gtest-test-part.cc
-  googletest/gtest-typed-test.cc
+  googletest/src/gtest-all.cc
   )
 
 add_llvm_library(gtest_main