Revert "Add a C++11 ThreadPool implementation in LLVM"
[oota-llvm.git] / unittests / Support / CMakeLists.txt
index 88596787dd0cc5f9ce2402539131a04f8da9ce67..fd8324c836da92699f67c4a96ab468c3a948606e 100644 (file)
@@ -1,26 +1,57 @@
 set(LLVM_LINK_COMPONENTS
+  ${LLVM_TARGETS_TO_BUILD}
   Support
-  Core
   )
 
 add_llvm_unittest(SupportTests
   AlignOfTest.cpp
   AllocatorTest.cpp
+  ArrayRecyclerTest.cpp
   BlockFrequencyTest.cpp
+  BranchProbabilityTest.cpp
   Casting.cpp
   CommandLineTest.cpp
-  ConstantRangeTest.cpp
+  CompressionTest.cpp
+  ConvertUTFTest.cpp
   DataExtractorTest.cpp
+  DwarfTest.cpp
+  EndianStreamTest.cpp
   EndianTest.cpp
-  IntegersSubsetTest.cpp
-  LeakDetectorTest.cpp
+  ErrorOrTest.cpp
+  FileOutputBufferTest.cpp
+  IteratorTest.cpp
+  LEB128Test.cpp
+  LineIteratorTest.cpp
+  LockFileManagerTest.cpp
+  MD5Test.cpp
   ManagedStatic.cpp
   MathExtrasTest.cpp
+  MemoryBufferTest.cpp
+  MemoryTest.cpp
   Path.cpp
-  raw_ostream_test.cpp
+  ProcessTest.cpp
+  ProgramTest.cpp
   RegexTest.cpp
+  ReplaceFileTest.cpp
+  ScaledNumberTest.cpp
+  SourceMgrTest.cpp
+  SpecialCaseListTest.cpp
+  StreamingMemoryObject.cpp
+  StringPool.cpp
   SwapByteOrderTest.cpp
-  TimeValue.cpp
-  ValueHandleTest.cpp
+  TargetRegistry.cpp
+  ThreadLocalTest.cpp
+  TimeValueTest.cpp
+  TrailingObjectsTest.cpp
+  UnicodeTest.cpp
+  YAMLIOTest.cpp
   YAMLParserTest.cpp
+  formatted_raw_ostream_test.cpp
+  raw_ostream_test.cpp
+  raw_pwrite_stream_test.cpp
   )
+
+# ManagedStatic.cpp uses <pthread>.
+if(LLVM_ENABLE_THREADS AND HAVE_LIBPTHREAD)
+  target_link_libraries(SupportTests pthread)
+endif()