Revert "Add a C++11 ThreadPool implementation in LLVM"
[oota-llvm.git] / unittests / Support / CMakeLists.txt
index 3c8a090c2bac4ee3f4c572e86bbf0ece36925c34..fd8324c836da92699f67c4a96ab468c3a948606e 100644 (file)
@@ -1,4 +1,5 @@
 set(LLVM_LINK_COMPONENTS
+  ${LLVM_TARGETS_TO_BUILD}
   Support
   )
 
@@ -31,14 +32,17 @@ add_llvm_unittest(SupportTests
   ProcessTest.cpp
   ProgramTest.cpp
   RegexTest.cpp
+  ReplaceFileTest.cpp
   ScaledNumberTest.cpp
   SourceMgrTest.cpp
   SpecialCaseListTest.cpp
   StreamingMemoryObject.cpp
   StringPool.cpp
   SwapByteOrderTest.cpp
+  TargetRegistry.cpp
   ThreadLocalTest.cpp
   TimeValueTest.cpp
+  TrailingObjectsTest.cpp
   UnicodeTest.cpp
   YAMLIOTest.cpp
   YAMLParserTest.cpp