Revert "Add a C++11 ThreadPool implementation in LLVM"
[oota-llvm.git] / unittests / Support / CMakeLists.txt
index 197561ebaa72c1e685e3ec914ad45e97ea9ee6fb..fd8324c836da92699f67c4a96ab468c3a948606e 100644 (file)
@@ -1,6 +1,6 @@
 set(LLVM_LINK_COMPONENTS
+  ${LLVM_TARGETS_TO_BUILD}
   Support
-  Core
   )
 
 add_llvm_unittest(SupportTests
@@ -8,33 +8,50 @@ add_llvm_unittest(SupportTests
   AllocatorTest.cpp
   ArrayRecyclerTest.cpp
   BlockFrequencyTest.cpp
+  BranchProbabilityTest.cpp
   Casting.cpp
   CommandLineTest.cpp
   CompressionTest.cpp
-  ConstantRangeTest.cpp
   ConvertUTFTest.cpp
   DataExtractorTest.cpp
+  DwarfTest.cpp
+  EndianStreamTest.cpp
   EndianTest.cpp
   ErrorOrTest.cpp
   FileOutputBufferTest.cpp
-  IntegersSubsetTest.cpp
-  LeakDetectorTest.cpp
-  LocaleTest.cpp
+  IteratorTest.cpp
+  LEB128Test.cpp
+  LineIteratorTest.cpp
   LockFileManagerTest.cpp
+  MD5Test.cpp
   ManagedStatic.cpp
   MathExtrasTest.cpp
-  MD5Test.cpp
   MemoryBufferTest.cpp
   MemoryTest.cpp
   Path.cpp
   ProcessTest.cpp
   ProgramTest.cpp
   RegexTest.cpp
+  ReplaceFileTest.cpp
+  ScaledNumberTest.cpp
+  SourceMgrTest.cpp
+  SpecialCaseListTest.cpp
+  StreamingMemoryObject.cpp
+  StringPool.cpp
   SwapByteOrderTest.cpp
+  TargetRegistry.cpp
+  ThreadLocalTest.cpp
   TimeValueTest.cpp
-  ValueHandleTest.cpp
+  TrailingObjectsTest.cpp
+  UnicodeTest.cpp
   YAMLIOTest.cpp
   YAMLParserTest.cpp
   formatted_raw_ostream_test.cpp
   raw_ostream_test.cpp
+  raw_pwrite_stream_test.cpp
   )
+
+# ManagedStatic.cpp uses <pthread>.
+if(LLVM_ENABLE_THREADS AND HAVE_LIBPTHREAD)
+  target_link_libraries(SupportTests pthread)
+endif()