Prevent further errors of omission when adding backend names.
[oota-llvm.git] / unittests / Support / CMakeLists.txt
index 3c8a090c2bac4ee3f4c572e86bbf0ece36925c34..564d189d49c2b646aa8f30e98623374f6aba4752 100644 (file)
@@ -1,4 +1,5 @@
 set(LLVM_LINK_COMPONENTS
+  ${LLVM_TARGETS_TO_BUILD}
   Support
   )
 
@@ -37,6 +38,7 @@ add_llvm_unittest(SupportTests
   StreamingMemoryObject.cpp
   StringPool.cpp
   SwapByteOrderTest.cpp
+  TargetRegistry.cpp
   ThreadLocalTest.cpp
   TimeValueTest.cpp
   UnicodeTest.cpp