Temporarily Revert "Nuke the old JIT." as it's not quite ready to
[oota-llvm.git] / unittests / ExecutionEngine / CMakeLists.txt
index 783c9b519216d61a0536f5f64de3b8cd6fc1ab69..5e462220e5cd6c1a93f0894e8b55f4d4aad64738 100644 (file)
@@ -10,9 +10,10 @@ add_llvm_unittest(ExecutionEngineTests
   ExecutionEngineTest.cpp
   )
 
-# Include MCJIT tests only if native arch is a built JIT target.
+# Include JIT/MCJIT tests only if native arch is a built JIT target.
 list(FIND LLVM_TARGETS_TO_BUILD "${LLVM_NATIVE_ARCH}" build_idx)
 list(FIND LLVM_TARGETS_WITH_JIT "${LLVM_NATIVE_ARCH}" jit_idx)
 if (NOT build_idx LESS 0 AND NOT jit_idx LESS 0)
+  add_subdirectory(JIT)
   add_subdirectory(MCJIT)
 endif()