[Orc] Move some code up into the JITCompileCallbackManager base class. NFC.
[oota-llvm.git] / unittests / ExecutionEngine / CMakeLists.txt
index 05e093e0c0b4001c14cebea58772a86eb485176f..302de9943ffe4c3e3e4095e1aab940503e57332e 100644 (file)
@@ -3,6 +3,7 @@ set(LLVM_LINK_COMPONENTS
   ExecutionEngine
   Interpreter
   MC
+  OrcJIT
   RuntimeDyld
   Support
   )
@@ -11,6 +12,8 @@ add_llvm_unittest(ExecutionEngineTests
   ExecutionEngineTest.cpp
   )
 
+add_subdirectory(Orc)
+
 # Include MCJIT tests only if native arch is a built JIT target.
 list(FIND LLVM_TARGETS_TO_BUILD "${LLVM_NATIVE_ARCH}" build_idx)
 list(FIND LLVM_TARGETS_WITH_JIT "${LLVM_NATIVE_ARCH}" jit_idx)