Adding tests for the Intel JIT event listener's MCJIT support.
[oota-llvm.git] / tools / CMakeLists.txt
index a253b33ecc8c0bc098bc07a3589c7a3fbd50ec4d..144e8ec3ea6323415a31dec6d90094edd3326757 100644 (file)
@@ -1,13 +1,10 @@
-# NOTE: The tools are organized into five groups of four consisting of one
-# large and three small executables. This is done to minimize memory load
-# in parallel builds.  Please retain this ordering.
+# NOTE: The tools are organized into groups of four consisting of one large and
+# three small executables. This is done to minimize memory load in parallel
+# builds.  Please retain this ordering.
 
 if( NOT WIN32 OR MSYS OR CYGWIN )
-  # It is useful to build llvm-config before the other tools, so we
-  # have a fresh LibDeps.txt for regenerating the hard-coded library
-  # dependencies. llvm-config/CMakeLists.txt takes care of this but we
-  # must keep llvm-config as the first entry on the list of tools to
-  # be built.
+  # We currently require 'sed' to build llvm-config, so don't try to build it
+  # on pure Win32.
   add_subdirectory(llvm-config)
 endif()
 
@@ -20,22 +17,45 @@ add_subdirectory(llc)
 add_subdirectory(llvm-ranlib)
 add_subdirectory(llvm-ar)
 add_subdirectory(llvm-nm)
+add_subdirectory(llvm-size)
 
-add_subdirectory(llvm-ld)
+add_subdirectory(llvm-cov)
 add_subdirectory(llvm-prof)
 add_subdirectory(llvm-link)
 add_subdirectory(lli)
 
 add_subdirectory(llvm-extract)
-add_subdirectory(llvm-db)
+add_subdirectory(llvm-diff)
+add_subdirectory(macho-dump)
+add_subdirectory(llvm-objdump)
+add_subdirectory(llvm-readobj)
+add_subdirectory(llvm-rtdyld)
+add_subdirectory(llvm-dwarfdump)
+if( LLVM_USE_INTEL_JITEVENTS )
+  add_subdirectory(llvm-jitlistener)
+endif( LLVM_USE_INTEL_JITEVENTS )
 
 add_subdirectory(bugpoint)
+add_subdirectory(bugpoint-passes)
 add_subdirectory(llvm-bcanalyzer)
-add_subdirectory(llvm-stub)
-add_subdirectory(llvmc)
+add_subdirectory(llvm-stress)
+add_subdirectory(llvm-mcmarkup)
 
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/clang/CMakeLists.txt )
-  add_subdirectory( ${CMAKE_CURRENT_SOURCE_DIR}/clang )
-endif( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/clang/CMakeLists.txt )
+add_subdirectory(llvm-symbolizer)
+
+if( NOT WIN32 )
+  add_subdirectory(lto)
+endif()
+
+if( LLVM_ENABLE_PIC )
+  # TODO: support other systems:
+  if( CMAKE_SYSTEM_NAME STREQUAL "Linux" )
+    add_subdirectory(gold)
+  endif()
+endif()
+
+add_llvm_external_project(clang)
+add_llvm_external_project(lld)
+add_llvm_external_project(polly)
 
 set(LLVM_COMMON_DEPENDS ${LLVM_COMMON_DEPENDS} PARENT_SCOPE)