Cleanup configuration for Cygwin
[oota-llvm.git] / projects / sample / autoconf / configure.ac
index 67e93aaecdb35c35b913e5cd5601d682bb33bd9d..b3ea7fa7fdd6b34c99093f8fb044b74e1e2867b6 100644 (file)
@@ -4,10 +4,10 @@ dnl **************************************************************************
 AC_INIT([[[SAMPLE]]],[[[x.xx]]],[bugs@yourdomain])
 
 dnl Place all of the extra autoconf files into the config subdirectory
-AC_CONFIG_AUX_DIR([autoconf])
+AC_CONFIG_AUX_DIR(autoconf)
 
 dnl Configure a header file
-AC_CONFIG_FILES([Makefile.common])
+AC_CONFIG_FILES(Makefile.common)
 
 dnl Configure Makefiles
 dnl List every Makefile that ecists within your source tree
@@ -54,10 +54,10 @@ dnl * Set the location of various third-party software packages
 dnl **************************************************************************
 
 dnl Location of LLVM source code
-AC_ARG_WITH(llvmsrc,AC_HELP_STRING([--with-llvmsrc],[Location of LLVM Source Code]),AC_SUBST(LLVM_SRC,[$withval]),AC_SUBST(LLVM_SRC,[`cd ${srcdir}/../..; pwd`]))
+AC_ARG_WITH(llvmsrc,AS_HELP_STRING([--with-llvmsrc],[Location of LLVM Source Code]),AC_SUBST(LLVM_SRC,[$withval]),AC_SUBST(LLVM_SRC,[`cd ${srcdir}/../..; pwd`]))
 
 dnl Location of LLVM object code
-AC_ARG_WITH(llvmobj,AC_HELP_STRING([--with-llvmobj],[Location of LLVM Object Code]),AC_SUBST(LLVM_OBJ,[$withval]),AC_SUBST(LLVM_OBJ,[`cd ../..; pwd`]))
+AC_ARG_WITH(llvmobj,AS_HELP_STRING([--with-llvmobj],[Location of LLVM Object Code]),AC_SUBST(LLVM_OBJ,[$withval]),AC_SUBST(LLVM_OBJ,[`cd ../..; pwd`]))
 
 dnl **************************************************************************
 dnl * Create the output files