MergedLoadStoreMotion pass
[oota-llvm.git] / lib / Transforms / Scalar / CMakeLists.txt
index af6fea707d5e84205a8651dd6c8a272abe014f8a..261ddda301505e6f93744ad55c70d6c199960f15 100644 (file)
@@ -1,36 +1,42 @@
 add_llvm_library(LLVMScalarOpts
-  ABCD.cpp
   ADCE.cpp
-  BasicBlockPlacement.cpp
-  CodeGenPrepare.cpp
-  CondPropagate.cpp
+  ConstantHoisting.cpp
   ConstantProp.cpp
+  CorrelatedValuePropagation.cpp
   DCE.cpp
   DeadStoreElimination.cpp
-  GEPSplitter.cpp
+  EarlyCSE.cpp
+  FlattenCFGPass.cpp
   GVN.cpp
   IndVarSimplify.cpp
-  InstructionCombining.cpp
   JumpThreading.cpp
   LICM.cpp
+  LoadCombine.cpp
   LoopDeletion.cpp
-  LoopIndexSplit.cpp
+  LoopIdiomRecognize.cpp
+  LoopInstSimplify.cpp
+  LoopRerollPass.cpp
   LoopRotation.cpp
   LoopStrengthReduce.cpp
-  LoopUnroll.cpp
+  LoopUnrollPass.cpp
   LoopUnswitch.cpp
+  LowerAtomic.cpp
   MemCpyOptimizer.cpp
+  MergedLoadStoreMotion.cpp
+  PartiallyInlineLibCalls.cpp
   Reassociate.cpp
   Reg2Mem.cpp
   SCCP.cpp
-  SCCVN.cpp
+  SROA.cpp
+  SampleProfile.cpp
   Scalar.cpp
   ScalarReplAggregates.cpp
+  Scalarizer.cpp
+  SeparateConstOffsetFromGEP.cpp
   SimplifyCFGPass.cpp
-  SimplifyHalfPowrLibCalls.cpp
-  SimplifyLibCalls.cpp
-  TailDuplication.cpp
+  Sink.cpp
+  StructurizeCFG.cpp
   TailRecursionElimination.cpp
   )
 
-target_link_libraries (LLVMScalarOpts LLVMTransformUtils)
+add_dependencies(LLVMScalarOpts intrinsics_gen)