AMDGPU: Add pass to detect used kernel features
[oota-llvm.git] / lib / Target / AMDGPU / CMakeLists.txt
index 1dc2c70fa37aa195505694879e5aab618d2832db..09e750be789c4851311428cc1af302daed6c0166 100644 (file)
@@ -6,45 +6,64 @@ tablegen(LLVM AMDGPUGenDAGISel.inc -gen-dag-isel)
 tablegen(LLVM AMDGPUGenCallingConv.inc -gen-callingconv)
 tablegen(LLVM AMDGPUGenSubtargetInfo.inc -gen-subtarget)
 tablegen(LLVM AMDGPUGenIntrinsics.inc -gen-tgt-intrinsic)
-tablegen(LLVM AMDGPUGenCodeEmitter.inc -gen-emitter)
+tablegen(LLVM AMDGPUGenMCCodeEmitter.inc -gen-emitter)
 tablegen(LLVM AMDGPUGenDFAPacketizer.inc -gen-dfa-packetizer)
+tablegen(LLVM AMDGPUGenAsmWriter.inc -gen-asm-writer)
+tablegen(LLVM AMDGPUGenAsmMatcher.inc -gen-asm-matcher)
 add_public_tablegen_target(AMDGPUCommonTableGen)
 
 add_llvm_target(AMDGPUCodeGen
-  AMDIL7XXDevice.cpp
   AMDILCFGStructurizer.cpp
-  AMDILDevice.cpp
-  AMDILDeviceInfo.cpp
-  AMDILEvergreenDevice.cpp
-  AMDILFrameLowering.cpp
-  AMDILInstrInfo.cpp
-  AMDILIntrinsicInfo.cpp
-  AMDILISelDAGToDAG.cpp
-  AMDILISelLowering.cpp
-  AMDILNIDevice.cpp
-  AMDILPeepholeOptimizer.cpp
-  AMDILRegisterInfo.cpp
-  AMDILSIDevice.cpp
-  AMDILSubtarget.cpp
+  AMDGPUAlwaysInlinePass.cpp
+  AMDGPUAnnotateKernelFeatures.cpp
+  AMDGPUAsmPrinter.cpp
+  AMDGPUDiagnosticInfoUnsupported.cpp
+  AMDGPUFrameLowering.cpp
+  AMDGPUHSATargetObjectFile.cpp
+  AMDGPUIntrinsicInfo.cpp
+  AMDGPUISelDAGToDAG.cpp
+  AMDGPUMCInstLower.cpp
+  AMDGPUMachineFunction.cpp
+  AMDGPUOpenCLImageTypeLoweringPass.cpp
+  AMDGPUSubtarget.cpp
   AMDGPUTargetMachine.cpp
+  AMDGPUTargetTransformInfo.cpp
   AMDGPUISelLowering.cpp
-  AMDGPUConvertToISA.cpp
   AMDGPUInstrInfo.cpp
+  AMDGPUPromoteAlloca.cpp
   AMDGPURegisterInfo.cpp
-  AMDGPUUtil.cpp
-  R600CodeEmitter.cpp
+  R600ClauseMergePass.cpp
+  R600ControlFlowFinalizer.cpp
+  R600EmitClauseMarkers.cpp
+  R600ExpandSpecialInstrs.cpp
   R600InstrInfo.cpp
   R600ISelLowering.cpp
-  R600KernelParameters.cpp
   R600MachineFunctionInfo.cpp
+  R600MachineScheduler.cpp
+  R600OptimizeVectorRegisters.cpp
+  R600Packetizer.cpp
   R600RegisterInfo.cpp
-  SIAssignInterpRegs.cpp
-  SICodeEmitter.cpp
+  R600TextureIntrinsicsReplacer.cpp
+  SIAnnotateControlFlow.cpp
+  SIFixControlFlowLiveIntervals.cpp
+  SIFixSGPRCopies.cpp
+  SIFixSGPRLiveRanges.cpp
+  SIFoldOperands.cpp
+  SIInsertWaits.cpp
   SIInstrInfo.cpp
   SIISelLowering.cpp
+  SILoadStoreOptimizer.cpp
+  SILowerControlFlow.cpp
+  SILowerI1Copies.cpp
   SIMachineFunctionInfo.cpp
+  SIPrepareScratchRegs.cpp
   SIRegisterInfo.cpp
+  SIShrinkInstructions.cpp
+  SITypeRewriter.cpp
   )
 
+add_subdirectory(AsmParser)
+add_subdirectory(InstPrinter)
 add_subdirectory(TargetInfo)
 add_subdirectory(MCTargetDesc)
+add_subdirectory(Utils)