Revert "Add a C++11 ThreadPool implementation in LLVM"
[oota-llvm.git] / lib / Support / CMakeLists.txt
index 0db4055f71136697ef07840a334252772ff8da5f..784e00e15b9e897d0337193c882be8ecdf9c8f14 100644 (file)
@@ -1,7 +1,8 @@
 set(system_libs)
 if( NOT MSVC )
   if( MINGW )
-    set(system_libs ${system_libs} psapi shell32 ole32)
+    # libuuid required for FOLDERID_Profile usage in lib/Support/Windows/Path.inc.
+    set(system_libs ${system_libs} psapi shell32 ole32 uuid)
   elseif( CMAKE_HOST_UNIX )
     if( HAVE_LIBRT )
       set(system_libs ${system_libs} rt)
@@ -88,7 +89,6 @@ add_llvm_library(LLVMSupport
   StringRef.cpp
   SystemUtils.cpp
   TargetParser.cpp
-  TargetTuple.cpp
   Timer.cpp
   ToolOutputFile.cpp
   Triple.cpp