[Orc] Move SectionMemoryManager's implementation from MCJIT to ExecutionEngine.
[oota-llvm.git] / lib / ExecutionEngine / CMakeLists.txt
index b5632d2bc5c35c38ec0b20c923df644f0e408da9..d2c33cda1a625d743053b675c98d1177dbf33d09 100644 (file)
@@ -1,8 +1,23 @@
+
+
 add_llvm_library(LLVMExecutionEngine
   ExecutionEngine.cpp
   ExecutionEngineBindings.cpp
+  GDBRegistrationListener.cpp
+  RTDyldMemoryManager.cpp
+  SectionMemoryManager.cpp
+  TargetSelect.cpp
   )
 
 add_subdirectory(Interpreter)
-add_subdirectory(JIT)
 add_subdirectory(MCJIT)
+add_subdirectory(Orc)
+add_subdirectory(RuntimeDyld)
+
+if( LLVM_USE_OPROFILE )
+  add_subdirectory(OProfileJIT)
+endif( LLVM_USE_OPROFILE )
+
+if( LLVM_USE_INTEL_JITEVENTS )
+  add_subdirectory(IntelJITEvents)
+endif( LLVM_USE_INTEL_JITEVENTS )