Taints the non-acquire RMW's store address with the load part
[oota-llvm.git] / lib / CodeGen / CMakeLists.txt
index 9c63dc7a0fd8c81751d1ff5910ff99e47197998f..765b5ab9a5770a7be1198778023835f8d2a8b1a6 100644 (file)
@@ -25,6 +25,7 @@ add_llvm_library(LLVMCodeGen
   ExecutionDepsFix.cpp
   ExpandISelPseudos.cpp
   ExpandPostRAPseudos.cpp
+  LiveDebugValues.cpp
   FaultMaps.cpp
   FuncletLayout.cpp
   GCMetadata.cpp
@@ -120,6 +121,7 @@ add_llvm_library(LLVMCodeGen
   StackMaps.cpp
   StatepointExampleGC.cpp
   TailDuplication.cpp
+  TaintRelaxedAtomicsUtils.cpp
   TargetFrameLoweringImpl.cpp
   TargetInstrInfo.cpp
   TargetLoweringBase.cpp