CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally.
[oota-llvm.git] / examples / ParallelJIT / CMakeLists.txt
index fbdc6e5fc10b4ecc2516737566bba566e06181b0..91ac5ef4675128d85f2b8d348cf8303ffb821d4a 100644 (file)
@@ -1,9 +1,9 @@
-set(LLVM_LINK_COMPONENTS jit interpreter nativecodegen)
-
 add_llvm_example(ParallelJIT
   ParallelJIT.cpp
   )
 
+add_llvm_link_components(ParallelJIT jit interpreter nativecodegen)
+
 if(HAVE_LIBPTHREAD)
   target_link_libraries(ParallelJIT pthread)
 endif(HAVE_LIBPTHREAD)