Taints the non-acquire RMW's store address with the load part
[oota-llvm.git] / examples / Kaleidoscope / CMakeLists.txt
index 9a18aae30534f946b0cb806ab9f79dde0331fa83..32664aa2a22721dc35d5e56095273ebe804e8d99 100644 (file)
@@ -1,5 +1,16 @@
-set(LLVM_LINK_COMPONENTS core jit native)
+add_custom_target(Kaleidoscope)
+set_target_properties(Kaleidoscope PROPERTIES FOLDER Examples)
 
-add_llvm_example(Kaleidoscope
-  toy.cpp
-  )
+macro(add_kaleidoscope_chapter name)
+  add_dependencies(Kaleidoscope ${name})
+  add_llvm_example(${name} ${ARGN})
+endmacro(add_kaleidoscope_chapter name)
+
+add_subdirectory(Chapter2)
+add_subdirectory(Chapter3)
+add_subdirectory(Chapter4)
+add_subdirectory(Chapter5)
+add_subdirectory(Chapter6)
+add_subdirectory(Chapter7)
+add_subdirectory(Chapter8)
+add_subdirectory(Orc)