Add bogus conditional branch before stlx
[oota-llvm.git] / examples / ExceptionDemo / CMakeLists.txt
index d6619155684341eec5e3f9daa3d2342d9aa56e84..793cf291ca6f110eae23c396e24c2ee3cd050bcd 100644 (file)
@@ -1,5 +1,21 @@
-set(LLVM_LINK_COMPONENTS jit nativecodegen)
+set(LLVM_LINK_COMPONENTS
+  Core
+  ExecutionEngine
+  MC
+  MCJIT
+  RuntimeDyld
+  Support
+  Target
+  nativecodegen
+  )
+
+# Enable EH and RTTI for this demo
+if(NOT LLVM_ENABLE_EH)
+  message(FATAL_ERROR "ExceptionDemo must require EH.")
+endif()
 
 add_llvm_example(ExceptionDemo
   ExceptionDemo.cpp
   )
+
+export_executable_symbols(ExceptionDemo)