Add bogus conditional branch before stlx
[oota-llvm.git] / examples / CMakeLists.txt
index f98c403deb0b90ef3d6e9d8f73642374c44d847d..5727066d6227b37e3615a9bc057a9cbf703322ca 100644 (file)
@@ -4,7 +4,7 @@ add_subdirectory(HowToUseJIT)
 add_subdirectory(Kaleidoscope)
 add_subdirectory(ModuleMaker)
 
-if( ( NOT WIN32 ) AND ( NOT "${LLVM_NATIVE_ARCH}" STREQUAL "ARM" ) )
+if(LLVM_ENABLE_EH AND (NOT WIN32) AND (NOT "${LLVM_NATIVE_ARCH}" STREQUAL "ARM"))
     add_subdirectory(ExceptionDemo)
 endif()