Merging r258436:
[oota-llvm.git] / examples / CMakeLists.txt
index f60c0eda030612b50e69b91b6532e3abf2a82f8d..5727066d6227b37e3615a9bc057a9cbf703322ca 100644 (file)
@@ -4,13 +4,10 @@ add_subdirectory(HowToUseJIT)
 add_subdirectory(Kaleidoscope)
 add_subdirectory(ModuleMaker)
 
-if( NOT WIN32 )
+if(LLVM_ENABLE_EH AND (NOT WIN32) AND (NOT "${LLVM_NATIVE_ARCH}" STREQUAL "ARM"))
     add_subdirectory(ExceptionDemo)
 endif()
 
-include(CheckIncludeFile)
-check_include_file(pthread.h HAVE_PTHREAD_H)
-
 if( HAVE_PTHREAD_H )
   add_subdirectory(ParallelJIT)
 endif( HAVE_PTHREAD_H )