Make the text of this file a little more useful.
[oota-llvm.git] / llvm.spec
1 Summary: Static and JIT research compiler infrastructure
2 Name: llvm
3 Version: 1.3
4 Release: 0
5 License: U of Illinois/NCSA Open Source License
6 Group: Development/Languages
7 Source0: llvm.tar.gz
8 URL: http://llvm.cs.uiuc.edu/releases/index.html
9 #BuildRequires: llvm-gcc
10 # (someday...)
11 BuildRoot: %{_tmppath}/%{name}-root
12 Requires: /sbin/ldconfig
13
14 %description
15 LLVM is a new infrastructure designed for compile-time, link-time, runtime,
16 and "idle-time" optimization of programs from arbitrary programming languages.
17 LLVM is written in C++ and has been developed since 2000 at the
18 University of Illinois. It currently supports compilation of C and C++
19 programs, using front-ends derived from GCC 3.4.
20
21 %prep
22 %setup -q -n llvm
23
24 %build
25 ./configure \
26 --prefix=%{_prefix} \
27 --bindir=%{_bindir} \
28 --datadir=%{_datadir} \
29 --includedir=%{_includedir} \
30 --libdir=%{_libdir}
31 make
32
33 %install
34 rm -rf %{buildroot}
35 make install DESTDIR=%{buildroot}
36
37 %clean
38 rm -rf %{buildroot}
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %files
45 %defattr(-, root, root)
46 %doc CREDITS.TXT LICENSE.TXT README.txt docs/*.{html,css,gif,jpg} docs/CommandGuide
47 %{_bindir}/*
48 %{_libdir}/*.o
49 %{_libdir}/*.a
50 %{_libdir}/*.so
51 %{_includedir}/llvm
52
53 %changelog
54 * Mon Feb 09 2003 Brian R. Gaeke
55 - Initial working version of RPM spec file.
56