[OCaml] Expose Llvm.parse_command_line_options.
[oota-llvm.git] / bindings / ocaml / llvm / META.llvm.in
1 name = "llvm"
2 version = "@PACKAGE_VERSION@"
3 description = "LLVM OCaml bindings"
4 archive(byte) = "llvm.cma"
5 archive(native) = "llvm.cmxa"
6 exists_if(toplevel) = "dllllvm.so"
7 directory = "."
8
9 package "analysis" (
10     requires = "llvm"
11     version = "@PACKAGE_VERSION@"
12     description = "Intermediate representation analysis for LLVM"
13     archive(byte) = "llvm_analysis.cma"
14     archive(native) = "llvm_analysis.cmxa"
15 )
16
17 package "bitreader" (
18     requires = "llvm"
19     version  = "@PACKAGE_VERSION@"
20     description = "Bitcode reader for LLVM"
21     archive(byte) = "llvm_bitreader.cma"
22     archive(native) = "llvm_bitreader.cmxa"
23 )
24
25 package "bitwriter" (
26     requires = "llvm,unix"
27     version = "@PACKAGE_VERSION@"
28     description = "Bitcode writer for LLVM"
29     archive(byte) = "llvm_bitwriter.cma"
30     archive(native) = "llvm_bitwriter.cmxa"
31 )
32
33 package "executionengine" (
34     requires = "llvm,llvm.target"
35     version = "@PACKAGE_VERSION@"
36     description = "JIT and Interpreter for LLVM"
37     archive(byte) = "llvm_executionengine.cma"
38     archive(native) = "llvm_executionengine.cmxa"
39 )
40
41 package "ipo" (
42     requires = "llvm"
43     version  = "@PACKAGE_VERSION@"
44     description = "IPO Transforms for LLVM"
45     archive(byte) = "llvm_ipo.cma"
46     archive(native) = "llvm_ipo.cmxa"
47 )
48
49 package "irreader" (
50     requires = "llvm"
51     version  = "@PACKAGE_VERSION@"
52     description = "IR assembly reader for LLVM"
53     archive(byte) = "llvm_irreader.cma"
54     archive(native) = "llvm_irreader.cmxa"
55 )
56
57 package "scalar_opts" (
58     requires = "llvm"
59     version = "@PACKAGE_VERSION@"
60     description = "Scalar Transforms for LLVM"
61     archive(byte) = "llvm_scalar_opts.cma"
62     archive(native) = "llvm_scalar_opts.cmxa"
63 )
64
65 package "vectorize" (
66     requires = "llvm"
67     version = "@PACKAGE_VERSION@"
68     description = "Vector Transforms for LLVM"
69     archive(byte) = "llvm_vectorize.cma"
70     archive(native) = "llvm_vectorize.cmxa"
71 )
72
73 package "passmgr_builder" (
74     requires = "llvm"
75     version = "@PACKAGE_VERSION@"
76     description = "Pass Manager Builder for LLVM"
77     archive(byte) = "llvm_passmgr_builder.cma"
78     archive(native) = "llvm_passmgr_builder.cmxa"
79 )
80
81 package "target" (
82     requires = "llvm"
83     version  = "@PACKAGE_VERSION@"
84     description = "Target Information for LLVM"
85     archive(byte) = "llvm_target.cma"
86     archive(native) = "llvm_target.cmxa"
87 )
88
89 package "linker" (
90     requires = "llvm"
91     version  = "@PACKAGE_VERSION@"
92     description = "Intermediate Representation Linker for LLVM"
93     archive(byte) = "llvm_linker.cma"
94     archive(native) = "llvm_linker.cmxa"
95 )
96
97 package "all_backends" (
98     requires = "llvm"
99     version  = "@PACKAGE_VERSION@"
100     description = "All backends for LLVM"
101     archive(byte) = "llvm_all_backends.cma"
102     archive(native) = "llvm_all_backends.cmxa"
103 )