Merge pull request #44 from eugenyk/master
[libcds.git] / tests / CMakeLists.txt
index ea088b8de3bf8ca869ad6b11c06da63d3685acc3..3de95852f47c997a3d398141975d5bd642fbb780 100644 (file)
@@ -5,9 +5,13 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR})
 set(SOURCES cppunit/test_main.cpp
             cppunit/thread.cpp
             unit/michael_alloc.cpp
-            unit/ellen_bintree_update_desc_pool.cpp)
+            unit/ellen_bintree_update_desc_pool.cpp
+            hashing/city.cpp)
 
 add_library(${TEST_COMMON} OBJECT ${SOURCES})
 
 add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/test-hdr)
-add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/unit)
\ No newline at end of file
+add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/unit)
+
+file(GLOB CONF_FILES ${PROJECT_SOURCE_DIR}/tests/data/*.conf)
+file(COPY ${CONF_FILES} DESTINATION ${EXECUTABLE_OUTPUT_PATH})
\ No newline at end of file