Added internal statistics for LazyList
[libcds.git] / test / unit / list / CMakeLists.txt
index 96f7f65f1a782c38cd96a084f488323ec1600b72..407dd5105cad36035038d0027aed3f40ed150150 100644 (file)
@@ -2,6 +2,8 @@ set(PACKAGE_NAME unit-list)
 
 set(CDSGTEST_LIST_SOURCES
     ../main.cpp
+    intrusive_iterable_dhp.cpp
+    intrusive_iterable_hp.cpp
     intrusive_lazy_hp.cpp
     intrusive_lazy_dhp.cpp
     intrusive_lazy_nogc.cpp
@@ -18,10 +20,38 @@ set(CDSGTEST_LIST_SOURCES
     intrusive_michael_rcu_gpt.cpp
     intrusive_michael_rcu_shb.cpp
     intrusive_michael_rcu_sht.cpp
+    kv_lazy_hp.cpp
+    kv_lazy_dhp.cpp
+    kv_lazy_nogc.cpp
+    kv_lazy_rcu_gpb.cpp
+    kv_lazy_rcu_gpi.cpp
+    kv_lazy_rcu_gpt.cpp
+    kv_lazy_rcu_shb.cpp
+    kv_lazy_rcu_sht.cpp
+    kv_michael_hp.cpp
+    kv_michael_dhp.cpp
+    kv_michael_nogc.cpp
+    kv_michael_rcu_gpb.cpp
+    kv_michael_rcu_gpi.cpp
+    kv_michael_rcu_gpt.cpp
+    kv_michael_rcu_shb.cpp
+    kv_michael_rcu_sht.cpp
     lazy_hp.cpp
     lazy_dhp.cpp
+    lazy_nogc.cpp
+    lazy_rcu_gpb.cpp
+    lazy_rcu_gpi.cpp
+    lazy_rcu_gpt.cpp
+    lazy_rcu_shb.cpp
+    lazy_rcu_sht.cpp
     michael_hp.cpp
     michael_dhp.cpp
+    michael_nogc.cpp
+    michael_rcu_gpb.cpp
+    michael_rcu_gpi.cpp
+    michael_rcu_gpt.cpp
+    michael_rcu_shb.cpp
+    michael_rcu_sht.cpp
 )
 
 include_directories(