[CI] Changed CMake scripts for tests
[libcds.git] / test / stress / set / insdel_string / CMakeLists.txt
index 0b557e35d6e0156f1b2e0ef6bc2eeef4b116ca8b..84212ff7da77ef10fc11e22858946e63c0bdff2e 100644 (file)
@@ -19,12 +19,6 @@ include_directories(
 )
 
 add_executable(${PACKAGE_NAME} ${CDSSTRESS_SET_INSDEL_STRING_SOURCES} $<TARGET_OBJECTS:${CDSSTRESS_FRAMEWORK_LIBRARY}>)
-target_link_libraries(${PACKAGE_NAME} 
-    ${CDS_SHARED_LIBRARY}
-    ${GTEST_LIBRARY}
-    ${Boost_THREAD_LIBRARY}
-    ${Boost_SYSTEM_LIBRARY}
-    ${CMAKE_THREAD_LIBS_INIT}
-)
+target_link_libraries(${PACKAGE_NAME} ${CDS_TEST_LIBRARIES})
 
 add_test(NAME ${PACKAGE_NAME} COMMAND ${PACKAGE_NAME} WORKING_DIRECTORY ${EXECUTABLE_OUTPUT_PATH})
\ No newline at end of file