Adds parallel junction map test cases
[junction.git] / test / CMakeLists.txt
index c7b749339232eeee9a1b1bef7ee65c39919e5de0..fe8a11e6f0cdc67b05e2031e8ba0470d6737a5dc 100644 (file)
@@ -1,16 +1,25 @@
 cmake_minimum_required(VERSION 2.8.5)
 
-set(PACKAGE_NAME stress-sequential-junction)
-set(JUNCTION_TEST_SOURCES
-    junction_driver.cpp
+set(CMAKE_CONFIGURATION_TYPES "Release" CACHE INTERNAL "Build configs")
+
+include_directories(
+    /scratch/googletest/googletest/include/
 )
 
-set(CMAKE_CONFIGURATION_TYPES "Release" CACHE INTERNAL "Build configs")
+set(SEQUENTIAL_DRIVER stress-sequential-junction)
+set(PARALLEL_DRIVER stress-parallel-junction)
 
 set(JUNCTION_LIB
   junction
   turf
+  # AArch64 lib
+  /scratch/googletest/googletest/libgtest.a
+  # x86 lib
+  #/scratch/googletest/libgtest.a
 )
 
-add_executable(${PACKAGE_NAME} ${JUNCTION_TEST_SOURCES})
-target_link_libraries(${PACKAGE_NAME} ${JUNCTION_LIB})
+add_executable(${SEQUENTIAL_DRIVER} junction_sequential_driver.cpp)
+target_link_libraries(${SEQUENTIAL_DRIVER} ${JUNCTION_LIB})
+
+add_executable(${PARALLEL_DRIVER} junction_parallel_driver.cpp)
+target_link_libraries(${PARALLEL_DRIVER} ${JUNCTION_LIB})