Changes libcds library path
[junction.git] / test / CMakeLists.txt
index adb76de9bafce6fb10ec5570a9ccd28e929ae141..cfe1c54233b651152c20a62841641e718edec8fd 100644 (file)
@@ -4,12 +4,12 @@ set(CMAKE_CONFIGURATION_TYPES "Release" CACHE INTERNAL "Build configs")
 
 include_directories(
     /scratch/googletest/googletest/include
-    /scratch/benchmarks/libcds/test/include
-    /scratch/benchmarks/libcds
+    /scratch/benchmarks/libcds/orig-libcds/test/include
+    /scratch/benchmarks/libcds/orig-libcds
 )
 
 link_directories(
-    /scratch/benchmarks/libcds/build/bin
+    /scratch/benchmarks/libcds/orig-libcds/build/bin
     /scratch/googletest/googletest
 )
 
@@ -25,8 +25,8 @@ set(JUNCTION_LIB
   gtest
 )
 
-add_executable(${SEQUENTIAL_DRIVER} junction_sequential_driver.cpp)
+add_executable(${SEQUENTIAL_DRIVER} junction_sequential_driver.cpp main.cpp)
 target_link_libraries(${SEQUENTIAL_DRIVER} ${JUNCTION_LIB})
 
-add_executable(${PARALLEL_DRIVER} junction_parallel_driver.cpp)
+add_executable(${PARALLEL_DRIVER} junction_parallel_driver.cpp main.cpp)
 target_link_libraries(${PARALLEL_DRIVER} ${JUNCTION_LIB})