Changes libcds library path
[junction.git] / test / CMakeLists.txt
index 5deccdea01516e2bbb0af77ba88d51abbe463f7e..cfe1c54233b651152c20a62841641e718edec8fd 100644 (file)
@@ -1,24 +1,32 @@
 cmake_minimum_required(VERSION 2.8.5)
 
+set(CMAKE_CONFIGURATION_TYPES "Release" CACHE INTERNAL "Build configs")
+
 include_directories(
-    /scratch/googletest/googletest/include/
+    /scratch/googletest/googletest/include
+    /scratch/benchmarks/libcds/orig-libcds/test/include
+    /scratch/benchmarks/libcds/orig-libcds
 )
 
-set(PACKAGE_NAME stress-sequential-junction)
-set(JUNCTION_TEST_SOURCES
-    junction_driver.cpp
+link_directories(
+    /scratch/benchmarks/libcds/orig-libcds/build/bin
+    /scratch/googletest/googletest
 )
 
-set(CMAKE_CONFIGURATION_TYPES "Release" CACHE INTERNAL "Build configs")
+set(SEQUENTIAL_DRIVER stress-sequential-junction)
+set(PARALLEL_DRIVER stress-parallel-junction)
 
 set(JUNCTION_LIB
   junction
   turf
-  # AArch64 lib
-  /scratch/googletest/googletest/libgtest.a
-  # x86 lib
-  #/scratch/googletest/libgtest.a
+  # It's fine to link the lib compiled from original clang because we are only
+  # using the config parsing functionality.
+  stress-framework
+  gtest
 )
 
-add_executable(${PACKAGE_NAME} ${JUNCTION_TEST_SOURCES})
-target_link_libraries(${PACKAGE_NAME} ${JUNCTION_LIB})
+add_executable(${SEQUENTIAL_DRIVER} junction_sequential_driver.cpp main.cpp)
+target_link_libraries(${SEQUENTIAL_DRIVER} ${JUNCTION_LIB})
+
+add_executable(${PARALLEL_DRIVER} junction_parallel_driver.cpp main.cpp)
+target_link_libraries(${PARALLEL_DRIVER} ${JUNCTION_LIB})