Uses cdsstress library
[junction.git] / test / CMakeLists.txt
index fe8a11e6f0cdc67b05e2031e8ba0470d6737a5dc..adb76de9bafce6fb10ec5570a9ccd28e929ae141 100644 (file)
@@ -3,7 +3,14 @@ cmake_minimum_required(VERSION 2.8.5)
 set(CMAKE_CONFIGURATION_TYPES "Release" CACHE INTERNAL "Build configs")
 
 include_directories(
-    /scratch/googletest/googletest/include/
+    /scratch/googletest/googletest/include
+    /scratch/benchmarks/libcds/test/include
+    /scratch/benchmarks/libcds
+)
+
+link_directories(
+    /scratch/benchmarks/libcds/build/bin
+    /scratch/googletest/googletest
 )
 
 set(SEQUENTIAL_DRIVER stress-sequential-junction)
@@ -12,10 +19,10 @@ set(PARALLEL_DRIVER stress-parallel-junction)
 set(JUNCTION_LIB
   junction
   turf
-  # AArch64 lib
-  /scratch/googletest/googletest/libgtest.a
-  # x86 lib
-  #/scratch/googletest/libgtest.a
+  # It's fine to link the lib compiled from original clang because we are only
+  # using the config parsing functionality.
+  stress-framework
+  gtest
 )
 
 add_executable(${SEQUENTIAL_DRIVER} junction_sequential_driver.cpp)