Make UncaughtExceptionCounter public
[folly.git] / folly / test / Makefile.am
index a35455e1ccce1e1fd929745989ba95e44c264daf..f2785b38704c0760e4cc8995c72c04dd0691e90e 100644 (file)
@@ -18,7 +18,7 @@ TESTS= \
 
 check_LTLIBRARIES = libfollytestmain.la libgtest.la
 check_PROGRAMS =
-noinst_LTLIBRARIES = lib_thread_local_test.la
+noinst_LTLIBRARIES = thread_local_test_lib.la
 
 libgtest_la_CPPFLAGS = -Igtest-1.7.0 -Igtest-1.7.0/src
 libgtest_la_SOURCES = gtest-1.7.0/src/gtest-all.cc
@@ -33,10 +33,10 @@ libfollytestmain_la_SOURCES = $(libgtest_la_SOURCES) gtest-1.7.0/src/gtest_main.
 libfollytestmain_la_LIBADD = $(top_builddir)/libfolly.la
 endif
 
-lib_thread_local_test_la_CPPFLAGS = $(AM_CPPFLAGS)
-lib_thread_local_test_la_SOURCES = ThreadLocalTestLib.cpp
-lib_thread_local_test_la_LDFLAGS = -rpath /force_shared
-lib_thread_local_test_la_LIBADD = $(top_builddir)/libfolly.la
+thread_local_test_lib_la_CPPFLAGS = $(AM_CPPFLAGS)
+thread_local_test_lib_la_SOURCES = ThreadLocalTestLib.cpp
+thread_local_test_lib_la_LDFLAGS = -module -rpath /force_shared
+thread_local_test_lib_la_LIBADD = $(top_builddir)/libfolly.la
 
 noinst_HEADERS = FBStringTestBenchmarks.cpp.h \
        FBVectorTestBenchmarks.cpp.h
@@ -249,6 +249,10 @@ try_test_SOURCES = TryTest.cpp
 try_test_LDADD = libfollytestmain.la
 TESTS += try_test
 
+uncaught_exceptions_test_SOURCES = UncaughtExceptionsTest.cpp
+uncaught_exceptions_test_LDADD = libfollytestmain.la
+TESTS += uncaught_exceptions_test
+
 unit_test_SOURCES = UnitTest.cpp
 unit_test_LDADD = libfollytestmain.la
 TESTS += unit_test