Make UncaughtExceptionCounter public
[folly.git] / folly / test / Makefile.am
index 641c98cb6898700825072c71dad065f4c3a797f8..f2785b38704c0760e4cc8995c72c04dd0691e90e 100644 (file)
@@ -10,12 +10,15 @@ TESTS= \
        hash_test \
        timeout_queue_test \
        conv_test \
+       expected_test \
        range_test \
+       math_test \
        bits_test \
        bit_iterator_test
 
 check_LTLIBRARIES = libfollytestmain.la libgtest.la
 check_PROGRAMS =
+noinst_LTLIBRARIES = thread_local_test_lib.la
 
 libgtest_la_CPPFLAGS = -Igtest-1.7.0 -Igtest-1.7.0/src
 libgtest_la_SOURCES = gtest-1.7.0/src/gtest-all.cc
@@ -30,6 +33,11 @@ libfollytestmain_la_SOURCES = $(libgtest_la_SOURCES) gtest-1.7.0/src/gtest_main.
 libfollytestmain_la_LIBADD = $(top_builddir)/libfolly.la
 endif
 
+thread_local_test_lib_la_CPPFLAGS = $(AM_CPPFLAGS)
+thread_local_test_lib_la_SOURCES = ThreadLocalTestLib.cpp
+thread_local_test_lib_la_LDFLAGS = -module -rpath /force_shared
+thread_local_test_lib_la_LIBADD = $(top_builddir)/libfolly.la
+
 noinst_HEADERS = FBStringTestBenchmarks.cpp.h \
        FBVectorTestBenchmarks.cpp.h
 
@@ -37,6 +45,10 @@ spin_lock_test_SOURCES = SpinLockTest.cpp
 spin_lock_test_LDADD = libfollytestmain.la
 TESTS += spin_lock_test
 
+array_test_SOURCES = ArrayTest.cpp
+array_test_LDADD = libfollytestmain.la
+TESTS += array_test
+
 if RUN_ARCH_SPECIFIC_TESTS
 small_locks_test_SOURCES = SmallLocksTest.cpp
 small_locks_test_LDADD = libfollytestmain.la
@@ -67,7 +79,11 @@ sorted_vector_types_test_LDADD = libfollytestmain.la
 
 
 foreach_test_SOURCES = ForeachTest.cpp
-foreach_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+foreach_test_LDADD = libfollytestmain.la
+
+foreach_benchmark_SOURCES = ForeachBenchmark.cpp
+foreach_benchmark_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+check_PROGRAMS += foreach_benchmark
 
 hash_test_SOURCES = HashTest.cpp
 hash_test_LDADD = libfollytestmain.la
@@ -114,9 +130,15 @@ timeout_queue_test_LDADD = libfollytestmain.la
 conv_test_SOURCES = ConvTest.cpp
 conv_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
 
+expected_test_SOURCES = ExpectedTest.cpp
+expected_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+
 range_test_SOURCES = RangeTest.cpp
 range_test_LDADD = libfollytestmain.la
 
+math_test_SOURCES = MathTest.cpp
+math_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+
 bits_test_SOURCES = BitsTest.cpp
 bits_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
 
@@ -135,6 +157,10 @@ synchronized_test_SOURCES = SynchronizedTest.cpp
 synchronized_test_LDADD = libfollytestmain.la
 TESTS += synchronized_test
 
+lock_traits_test_SOURCES = LockTraitsTest.cpp
+lock_traits_test_LDADD = libfollytestmain.la
+TESTS += lock_traits_test
+
 concurrent_skiplist_test_SOURCES = ConcurrentSkipListTest.cpp
 concurrent_skiplist_test_LDADD = libfollytestmain.la
 TESTS += concurrent_skiplist_test
@@ -143,6 +169,10 @@ concurrent_skiplist_benchmark_SOURCES = ConcurrentSkipListBenchmark.cpp
 concurrent_skiplist_benchmark_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
 check_PROGRAMS += concurrent_skiplist_benchmark
 
+conv_benchmark_SOURCES = ConvBenchmark.cpp
+conv_benchmark_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+check_PROGRAMS += conv_benchmark
+
 histogram_test_SOURCES = HistogramTest.cpp
 histogram_test_LDADD = libfollytestmain.la
 TESTS += histogram_test
@@ -199,12 +229,39 @@ thread_name_test_SOURCES = ThreadNameTest.cpp
 thread_name_test_LDADD = libfollytestmain.la
 TESTS += thread_name_test
 
+indestructible_test_SOURCES = IndestructibleTest.cpp
+indestructible_test_LDADD = libfollytestmain.la
+TESTS += indestructible_test
+
+portability_clock_gettime_wrappers_test_SOURCES = ClockGettimeWrappersTest.cpp
+portability_clock_gettime_wrappers_test_LDADD = libfollytestmain.la
+TESTS += portability_clock_gettime_wrappers_test
+
+portability_time_test_SOURCES = ../portability/test/TimeTest.cpp
+portability_time_test_LDADD = libfollytestmain.la
+TESTS += portability_time_test
+
+portability_constexpr_test_SOURCES = ../portability/test/ConstexprTest.cpp
+portability_constexpr_test_LDADD = libfollytestmain.la
+TESTS += portability_constexpr_test
+
+try_test_SOURCES = TryTest.cpp
+try_test_LDADD = libfollytestmain.la
+TESTS += try_test
+
+uncaught_exceptions_test_SOURCES = UncaughtExceptionsTest.cpp
+uncaught_exceptions_test_LDADD = libfollytestmain.la
+TESTS += uncaught_exceptions_test
+
+unit_test_SOURCES = UnitTest.cpp
+unit_test_LDADD = libfollytestmain.la
+TESTS += unit_test
 
 futures_test_SOURCES = \
     ../futures/test/CollectTest.cpp \
     ../futures/test/ContextTest.cpp \
+    ../futures/test/ConversionTest.cpp \
     ../futures/test/CoreTest.cpp \
-    ../futures/test/ThreadedExecutorTest.cpp \
     ../futures/test/EnsureTest.cpp \
     ../futures/test/ExecutorTest.cpp \
     ../futures/test/FSMTest.cpp \
@@ -213,17 +270,17 @@ futures_test_SOURCES = \
     ../futures/test/HeaderCompileTest.cpp \
     ../futures/test/InterruptTest.cpp \
     ../futures/test/MapTest.cpp \
+    ../futures/test/NonCopyableLambdaTest.cpp \
     ../futures/test/PollTest.cpp \
     ../futures/test/PromiseTest.cpp \
     ../futures/test/ReduceTest.cpp \
     ../futures/test/RetryingTest.cpp \
+    ../futures/test/SelfDestructTest.cpp \
     ../futures/test/SharedPromiseTest.cpp \
     ../futures/test/ThenCompileTest.cpp \
     ../futures/test/ThenTest.cpp \
     ../futures/test/TimekeeperTest.cpp \
     ../futures/test/TimesTest.cpp \
-    ../futures/test/TryTest.cpp \
-    ../futures/test/UnitTest.cpp \
     ../futures/test/UnwrapTest.cpp \
     ../futures/test/ViaTest.cpp \
     ../futures/test/WaitTest.cpp \
@@ -235,4 +292,31 @@ futures_test_SOURCES = \
 futures_test_LDADD = libfollytestmain.la
 TESTS += futures_test
 
+function_test_SOURCES = \
+               FunctionRefTest.cpp \
+               FunctionTest.cpp
+function_test_LDADD = libfollytestmain.la
+TESTS += function_test
+
+ssl_test_SOURCES = \
+               ../ssl/test/OpenSSLHashTest.cpp
+ssl_test_LDADD = libfollytestmain.la -lcrypto
+TESTS += ssl_test
+
+mallctl_helper_test_SOURCES = MallctlHelperTest.cpp
+mallctl_helper_test_LDADD = libfollytestmain.la
+TESTS += mallctl_helper_test
+
+apply_tuple_test_SOURCES = ApplyTupleTest.cpp
+apply_tuple_test_LDADD = libfollytestmain.la
+TESTS += apply_tuple_test
+
+partial_test_SOURCES = PartialTest.cpp
+partial_test_LDADD = libfollytestmain.la
+TESTS += partial_test
+
+singleton_thread_local_test_SOURCES = SingletonThreadLocalTest.cpp
+singleton_thread_local_test_LDADD = libfollytestmain.la
+TESTS += singleton_thread_local_test
+
 check_PROGRAMS += $(TESTS)