Fix copyright lines for Bits.h and move BitsBenchmark.cpp
[folly.git] / folly / test / Makefile.am
index b55bc800d4826b362b91ffc961d257bffc22c678..9fb035f0edf0ca0e5c5c796d41c8c13f5fe3aaf6 100644 (file)
@@ -80,20 +80,27 @@ endif
 
 sorted_vector_types_test_SOURCES = sorted_vector_test.cpp
 sorted_vector_types_test_LDADD = libfollytestmain.la
+TESTS += sorted_vector_types_test
 
+container_access_test_SOURCES = ../container/test/AccessTest.cpp
+container_access_test_LDADD = libfollytestmain.la
+TESTS += container_access_test
 
 foreach_test_SOURCES = ../container/test/ForeachTest.cpp
 foreach_test_LDADD = libfollytestmain.la
+TESTS += foreach_test
 
 foreach_benchmark_SOURCES = ../container/test/ForeachBenchmark.cpp
 foreach_benchmark_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
 check_PROGRAMS += foreach_benchmark
 
-hash_test_SOURCES = HashTest.cpp
+hash_test_SOURCES = ../hash/test/HashTest.cpp
 hash_test_LDADD = libfollytestmain.la
+TESTS += hash_test
 
 invoke_test_SOURCES = ../functional/test/InvokeTest.cpp
 invoke_test_LDADD = libfollytestmain.la
+TESTS += invoke_test
 
 fbstring_test_using_jemalloc_SOURCES = FBStringTest.cpp
 fbstring_test_using_jemalloc_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
@@ -101,8 +108,9 @@ TESTS += fbstring_test_using_jemalloc
 
 thread_cached_int_test_SOURCES = ThreadCachedIntTest.cpp
 thread_cached_int_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+TESTS += thread_cached_int_test
 
-thread_id_test_SOURCES = system/test/ThreadIdTest.cpp
+thread_id_test_SOURCES = ../system/test/ThreadIdTest.cpp
 thread_id_test_LDADD = libfollytestmain.la
 TESTS += thread_id_test
 
@@ -136,24 +144,31 @@ TESTS += scope_guard_test
 
 timeout_queue_test_SOURCES = TimeoutQueueTest.cpp
 timeout_queue_test_LDADD = libfollytestmain.la
+TESTS += timeout_queue_test
 
 conv_test_SOURCES = ConvTest.cpp
 conv_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+TESTS += conv_test
 
 expected_test_SOURCES = ExpectedTest.cpp
 expected_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+TESTS += expected_test
 
 range_test_SOURCES = RangeTest.cpp
 range_test_LDADD = libfollytestmain.la
+TESTS += range_test
 
 math_test_SOURCES = MathTest.cpp
 math_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+TESTS += math_test
 
-bits_test_SOURCES = BitsTest.cpp
+bits_test_SOURCES = ../lang/test/BitsTest.cpp
 bits_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+TESTS += bits_test
 
 bit_iterator_test_SOURCES = BitIteratorTest.cpp
 bit_iterator_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
+TESTS += bit_iterator_test
 
 endian_test_SOURCES = EndianTest.cpp
 endian_test_LDADD = libfollytestmain.la
@@ -223,9 +238,11 @@ fingerprint_test_SOURCES = FingerprintTest.cpp
 fingerprint_test_LDADD = libfollytestmain.la $(top_builddir)/libfollybenchmark.la
 TESTS += fingerprint_test
 
+if HAVE_VARIABLE_TEMPLATES
 poly_test_SOURCES = PolyTest.cpp
 poly_test_LDADD = libfollytestmain.la
 TESTS += poly_test
+endif
 
 portability_test_SOURCES = PortabilityTest.cpp
 portability_test_LDADD = libfollytestmain.la
@@ -243,7 +260,7 @@ token_bucket_test_SOURCES = TokenBucketTest.cpp
 token_bucket_test_LDADD = libfollytestmain.la  $(top_builddir)/libfollybenchmark.la
 TESTS += token_bucket_test
 
-thread_name_test_SOURCES = system/ThreadNameTest.cpp
+thread_name_test_SOURCES = ../system/test/ThreadNameTest.cpp
 thread_name_test_LDADD = libfollytestmain.la
 TESTS += thread_name_test
 
@@ -326,10 +343,10 @@ function_test_SOURCES = \
 function_test_LDADD = libfollytestmain.la
 TESTS += function_test
 
-functional_test_SOURCES = \
-               FunctionalTest.cpp
-functional_test_LDADD = libfollytestmain.la
-TESTS += functional_test
+rvalue_reference_wrapper_test_SOURCES = \
+               ../lang/test/RValueReferenceWrapperTest.cpp
+rvalue_reference_wrapper_test_LDADD = libfollytestmain.la
+TESTS += rvalue_reference_wrapper_test
 
 ssl_test_SOURCES = \
                ../ssl/test/OpenSSLHashTest.cpp
@@ -340,11 +357,11 @@ mallctl_helper_test_SOURCES = ../memory/test/MallctlHelperTest.cpp
 mallctl_helper_test_LDADD = libfollytestmain.la
 TESTS += mallctl_helper_test
 
-apply_tuple_test_SOURCES = ApplyTupleTest.cpp
+apply_tuple_test_SOURCES = ../functional/test/ApplyTupleTest.cpp
 apply_tuple_test_LDADD = libfollytestmain.la
 TESTS += apply_tuple_test
 
-partial_test_SOURCES = PartialTest.cpp
+partial_test_SOURCES = ../functional/test/PartialTest.cpp
 partial_test_LDADD = libfollytestmain.la
 TESTS += partial_test
 
@@ -356,7 +373,7 @@ utility_test_SOURCES = UtilityTest.cpp
 utility_test_LDADD = libfollytestmain.la
 TESTS += utility_test
 
-iterator_test_SOURCES = IteratorTest.cpp
+iterator_test_SOURCES = ../container/test/IteratorTest.cpp
 iterator_test_LDADD = libfollytestmain.la
 TESTS += iterator_test