rename io::PortableSpinLock to SpinLock
[folly.git] / folly / test / Makefile.am
index afdcaabf8a0d1af9147e097eab105b6c8fec98de..151e836264793504f8e69669ab6a143f90e6000d 100644 (file)
@@ -26,6 +26,10 @@ libgtest_la_SOURCES = gtest-1.6.0/src/gtest-all.cc
 noinst_HEADERS = FBStringTestBenchmarks.cpp.h \
                 FBVectorTestBenchmarks.cpp.h
 
+small_locks_test_SOURCES = SpinLockTest.cpp
+small_locks_test_LDADD = libgtestmain.la $(top_builddir)/libfolly.la
+TESTS += spin_lock_test
+
 if HAVE_X86_64
 small_locks_test_SOURCES = SmallLocksTest.cpp
 small_locks_test_LDADD = libgtestmain.la $(top_builddir)/libfolly.la